aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-07-29 00:51:54 +0800
committervanilla <vanilla@FreeBSD.org>2013-07-29 00:51:54 +0800
commit689766cd7ad24e94476f9ef18d21a8a54b7a12b9 (patch)
treef1eb319d6ee508472314c6167610baa2584fb65f
parent0b51055e01814f6e4a88d208f726f2507532fb0f (diff)
downloadfreebsd-ports-gnome-689766cd7ad24e94476f9ef18d21a8a54b7a12b9.tar.gz
freebsd-ports-gnome-689766cd7ad24e94476f9ef18d21a8a54b7a12b9.tar.zst
freebsd-ports-gnome-689766cd7ad24e94476f9ef18d21a8a54b7a12b9.zip
Add libscrypt 1.1, c library for the scrypt key derivation function.
PR: ports/180903 Submitted by: Horia Racoviceanu <horia@racoviceanu.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/libscrypt/Makefile32
-rw-r--r--security/libscrypt/distinfo2
-rw-r--r--security/libscrypt/pkg-descr8
4 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 119ab006416f..2a1a504b2ecf 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -275,6 +275,7 @@
SUBDIR += libprelude
SUBDIR += libpreludedb
SUBDIR += libpwstor
+ SUBDIR += libscrypt
SUBDIR += libsectok
SUBDIR += libsodium
SUBDIR += libsparkcrypto
diff --git a/security/libscrypt/Makefile b/security/libscrypt/Makefile
new file mode 100644
index 000000000000..96ef27ff86b2
--- /dev/null
+++ b/security/libscrypt/Makefile
@@ -0,0 +1,32 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= libscrypt
+PORTVERSION= 1.1
+CATEGORIES= security
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= C library for the scrypt key derivation function
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= technion
+GH_COMMIT= 49f9136
+GH_TAGNAME= v${PORTVERSION}
+
+PLIST_FILES+= include/libscrypt.h \
+ lib/libscrypt.a \
+ lib/libscrypt.so \
+ lib/libscrypt.so.0
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^CC=gcc/d' -e '/CFLAGS=/s,$$, ${CFLAGS},' \
+ -e 's,/usr/local,${PREFIX},' ${WRKSRC}/Makefile
+
+regression-test: build
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+
+.include <bsd.port.mk>
diff --git a/security/libscrypt/distinfo b/security/libscrypt/distinfo
new file mode 100644
index 000000000000..66ae152e965e
--- /dev/null
+++ b/security/libscrypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libscrypt-1.1.tar.gz) = f6cec579980850604267566731e12d985f16739cd92b828fe28c326f6a7ee798
+SIZE (libscrypt-1.1.tar.gz) = 20276
diff --git a/security/libscrypt/pkg-descr b/security/libscrypt/pkg-descr
new file mode 100644
index 000000000000..ba8fb371c7c6
--- /dev/null
+++ b/security/libscrypt/pkg-descr
@@ -0,0 +1,8 @@
+Although the creator of scrypt has written an "example implementation", it
+doesn't satisfy the "simple library" requirement that prompts developers to
+implement it. Therefore, I've written my adaptation, which quite simply pulls
+the relevant parts from the original implementation, then adds a number of
+harnesses and simplified interfaces. The hope is that through this, any
+developer can utilise scrypt.
+
+WWW: http://www.lolware.net/libscrypt.html