aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-24 16:17:07 +0800
committerpav <pav@FreeBSD.org>2004-05-24 16:17:07 +0800
commit68ae40954da1d2c8791831426f01211ba02ec1d6 (patch)
treecdd84906125723b4404836149d3f3a85cdc25d9a
parented0b30d6dacf0aeaa4522a35bc624c137a37e9d9 (diff)
downloadfreebsd-ports-gnome-68ae40954da1d2c8791831426f01211ba02ec1d6.tar.gz
freebsd-ports-gnome-68ae40954da1d2c8791831426f01211ba02ec1d6.tar.zst
freebsd-ports-gnome-68ae40954da1d2c8791831426f01211ba02ec1d6.zip
- Update to 1.0
PR: ports/66833 Submitted by: Toni Viemero <toni.viemero@iki.fi> Approved by: maintainer
-rw-r--r--security/fwlogwatch/Makefile4
-rw-r--r--security/fwlogwatch/distinfo4
-rw-r--r--security/fwlogwatch/files/patch-Makefile19
-rw-r--r--security/fwlogwatch/files/patch-net.c10
-rw-r--r--security/fwlogwatch/pkg-descr16
-rw-r--r--security/fwlogwatch/pkg-plist1
6 files changed, 34 insertions, 20 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index 8b5df0d122fd..ce19d81451be 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -7,15 +7,13 @@
#
PORTNAME= fwlogwatch
-PORTVERSION= 0.9.3
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= http://www.kybs.de/boris/sw/
MAINTAINER= jim@corebsd.or.id
COMMENT= A packet filter and firewall log analyzer
-USE_BZIP2= yes
USE_GETTEXT= yes
USE_REINPLACE= yes
MAKE_ENV= MKDIR="${MKDIR}"
diff --git a/security/fwlogwatch/distinfo b/security/fwlogwatch/distinfo
index 90c83ed91640..fc37a0dda6c6 100644
--- a/security/fwlogwatch/distinfo
+++ b/security/fwlogwatch/distinfo
@@ -1,2 +1,2 @@
-MD5 (fwlogwatch-0.9.3.tar.bz2) = c7aa8286f38cf16b5ebba58df083bffc
-SIZE (fwlogwatch-0.9.3.tar.bz2) = 79650
+MD5 (fwlogwatch-1.0.tar.gz) = 7fff74be5a5c6277b771f6d963e3ac7e
+SIZE (fwlogwatch-1.0.tar.gz) = 105304
diff --git a/security/fwlogwatch/files/patch-Makefile b/security/fwlogwatch/files/patch-Makefile
index 9918f0d84edc..cd494f9df615 100644
--- a/security/fwlogwatch/files/patch-Makefile
+++ b/security/fwlogwatch/files/patch-Makefile
@@ -1,6 +1,7 @@
---- Makefile.orig Thu Oct 3 23:07:30 2002
-+++ Makefile Mon Mar 31 10:37:53 2003
-@@ -2,9 +2,9 @@
+--- Makefile.orig Sun Apr 4 17:42:16 2004
++++ Makefile Tue May 18 21:46:48 2004
+@@ -2,10 +2,10 @@
+ # $Id: Makefile,v 1.73 2004/04/04 14:42:16 bw Exp $
# Linux
-CC = gcc
@@ -14,7 +15,7 @@
# Solaris
#LIBS = -lnsl -lsocket -lcrypt -lz
-@@ -22,9 +22,12 @@
+@@ -23,9 +23,12 @@
#LIBS = -L/usr/local/lib -lz -lintl
# FreeBSD
@@ -30,7 +31,7 @@
# You might want to add -DSHORT_NAMES to CFLAGS if you only intend to
# analyze log formats with short list/chain/branch/interface names like
-@@ -37,12 +40,12 @@
+@@ -38,12 +41,12 @@
LFLAGS = -B #-f #-p -p -d
INSTALL = install
@@ -47,9 +48,9 @@
+CONF_DIR = ${INSTALL_DIR}/etc
+LOCALE_DIR = ${INSTALL_DIR}
- OBJS = cisco_ios.o cisco_pix.o compare.o ipchains.o ipfilter.o lancom.o \
- main.o modes.o net.o netfilter.o netscreen.o output.o parser.o \
-@@ -82,18 +85,23 @@
+ OBJS = cisco_ios.o cisco_pix.o compare.o ipchains.o ipfilter.o ipfw.o \
+ lancom.o main.o modes.o net.o netfilter.o netscreen.o output.o \
+@@ -85,19 +88,25 @@
$(INSTALL_PROGRAM) fwlogwatch $(INSTALL_DIR)/sbin/fwlogwatch
$(INSTALL_SCRIPT) contrib/fwlw_notify $(INSTALL_DIR)/sbin/fwlw_notify
$(INSTALL_SCRIPT) contrib/fwlw_respond $(INSTALL_DIR)/sbin/fwlw_respond
@@ -65,6 +66,8 @@
+ cd po; $(MAKE)
+ ${MKDIR} $(LOCALE_DIR)/share/locale/de/LC_MESSAGES
$(INSTALL_DATA) po/de.mo $(LOCALE_DIR)/share/locale/de/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} $(LOCALE_DIR)/share/locale/ja/LC_MESSAGES
+ $(INSTALL_DATA) po/ja.mo $(LOCALE_DIR)/share/locale/ja/LC_MESSAGES/fwlogwatch.mo
+ ${MKDIR} $(LOCALE_DIR)/share/locale/pt_BR/LC_MESSAGES
$(INSTALL_DATA) po/pt_BR.mo $(LOCALE_DIR)/share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
+ ${MKDIR} $(LOCALE_DIR)/share/locale/sv/LC_MESSAGES
diff --git a/security/fwlogwatch/files/patch-net.c b/security/fwlogwatch/files/patch-net.c
new file mode 100644
index 000000000000..5bd673180224
--- /dev/null
+++ b/security/fwlogwatch/files/patch-net.c
@@ -0,0 +1,10 @@
+--- net.c.orig Wed Mar 31 22:16:29 2004
++++ net.c Tue May 18 21:51:03 2004
+@@ -15,6 +15,7 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <signal.h>
++#include <limits.h>
+
+ #ifndef __OpenBSD__
+ #ifndef __FreeBSD__
diff --git a/security/fwlogwatch/pkg-descr b/security/fwlogwatch/pkg-descr
index 20e117b5d3c5..328dc3d34b36 100644
--- a/security/fwlogwatch/pkg-descr
+++ b/security/fwlogwatch/pkg-descr
@@ -3,17 +3,19 @@ fwlogwatch is a packet filter and firewall log analyzer
General features:
- Can detect and process log entries in the following formats:
- Linux ipchains, Linux netfilter/iptables, Solaris/BSD/Irix/HP-UX
- ipfilter, Cisco IOS and Cisco PIX.
- - Entries can be parsed in combined log files, the parsers to be used
- can be selected.
- - Gzip-compressed logs are supported.
+ ipfilter, BSD ipfw, Cisco IOS, Cisco PIX / FWSM, NetScreen,
+ Windows XP firewall, Elsa Lancom router, Snort IDS
+ - Entries can be parsed from single, multiple and combined log files,
+ the parsers to be used can be selected.
+ - Gzip-compressed logs are supported transparently.
- Can separate recent from old entries and detects timewarps in log files.
- Can recognize 'last message repeated' entries concerning the firewall.
- Integrated resolver for protocols, services and host names.
- Can do lookups in the whois database.
- Own DNS and whois information cache for faster lookups.
- - Ports and hosts can be selected or excluded as needed.
+ - Hosts, networks, ports, chains and branches (targets) can be selected or
+ excluded as needed.
- Support for internationalization (available in english, german,
- portuguese and chinese).
+ portuguese, simplified and traditional chinese, swedish and japanese).
-WWW: http://cert.uni-stuttgart.de/projects/fwlogwatch/
+WWW: http://fwlogwatch.inside-security.de/
diff --git a/security/fwlogwatch/pkg-plist b/security/fwlogwatch/pkg-plist
index 29c9ff47c9c4..01ff07016534 100644
--- a/security/fwlogwatch/pkg-plist
+++ b/security/fwlogwatch/pkg-plist
@@ -5,6 +5,7 @@ sbin/fwlogwatch
sbin/fwlw_notify
sbin/fwlw_respond
share/locale/de/LC_MESSAGES/fwlogwatch.mo
+share/locale/ja/LC_MESSAGES/fwlogwatch.mo
share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
share/locale/sv/LC_MESSAGES/fwlogwatch.mo
share/locale/zh_CN/LC_MESSAGES/fwlogwatch.mo