aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-10-26 23:45:51 +0800
committerhq <hq@FreeBSD.org>2004-10-26 23:45:51 +0800
commit696b67b50bff594bc80e97e5bdf6de074444022d (patch)
treed2090ea6c36095a8296861da44435ef1cf092356
parent5abb576ef6da571508ea165287bb03145ff9e04f (diff)
downloadfreebsd-ports-gnome-696b67b50bff594bc80e97e5bdf6de074444022d.tar.gz
freebsd-ports-gnome-696b67b50bff594bc80e97e5bdf6de074444022d.tar.zst
freebsd-ports-gnome-696b67b50bff594bc80e97e5bdf6de074444022d.zip
XOM is a new XML object model. It is an open source (LGPL), tree-based API for
processing XML with Java that strives for correctness and simplicity. XOM is designed to be easy to learn and easy to use. It works very straight-forwardly, and has a very shallow learning curve. Assuming you're already familiar with XML, you should be able to get up and running with XOM very quickly. WWW: http://www.cafeconleche.org/XOM/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xom/Makefile47
-rw-r--r--textproc/xom/distinfo2
-rw-r--r--textproc/xom/pkg-descr9
4 files changed, 59 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 1a8707a20e11..5ceb83c26496 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -670,6 +670,7 @@
SUBDIR += xmlstarlet
SUBDIR += xmlto
SUBDIR += xmlwrapp
+ SUBDIR += xom
SUBDIR += xp
SUBDIR += xpp3
SUBDIR += xslide.el
diff --git a/textproc/xom/Makefile b/textproc/xom/Makefile
new file mode 100644
index 000000000000..b82a7f094d31
--- /dev/null
+++ b/textproc/xom/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: xom
+# Date created: 2004-10-26
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xom
+PORTVERSION= 1.0b6
+CATEGORIES= textproc java
+MASTER_SITES= http://www.cafeconleche.org/XOM/
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Open source (LGPL), tree-based API for processing XML with Java
+
+RUN_DEPENDS= ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j \
+ ${JAVALIBDIR}/xalan.jar:${PORTSDIR}/textproc/xalan-j
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/XOM
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+PORTDOCS= overview.html apidocs
+PLIST_FILES+= %%EXAMPLESDIR%%/xom-samples.jar
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/xom-samples.jar ${EXAMPLESDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}/apidocs
+ @cd ${WRKSRC}/ && ${FIND} ${PORTDOCS} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xom/distinfo b/textproc/xom/distinfo
new file mode 100644
index 000000000000..cdcc2d69e26c
--- /dev/null
+++ b/textproc/xom/distinfo
@@ -0,0 +1,2 @@
+MD5 (xom-1.0b6.tar.gz) = 0729b77c3b728fa670ee5514b22ce461
+SIZE (xom-1.0b6.tar.gz) = 3520262
diff --git a/textproc/xom/pkg-descr b/textproc/xom/pkg-descr
new file mode 100644
index 000000000000..71e5ad3e6548
--- /dev/null
+++ b/textproc/xom/pkg-descr
@@ -0,0 +1,9 @@
+XOM is a new XML object model. It is an open source (LGPL), tree-based API for
+processing XML with Java that strives for correctness and simplicity.
+
+XOM is designed to be easy to learn and easy to use. It works very
+straight-forwardly, and has a very shallow learning curve. Assuming you're
+already familiar with XML, you should be able to get up and running with XOM
+very quickly.
+
+WWW: http://www.cafeconleche.org/XOM/