aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:36:46 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:36:46 +0800
commit6971f44eb4c66755b51b2ed9210ffefc6166aff1 (patch)
tree751c528bdb9ec717caecbcc650821ddc8ea678a4
parent73e9df16f30aa62cae232c4ea9508d42871288d8 (diff)
downloadfreebsd-ports-gnome-6971f44eb4c66755b51b2ed9210ffefc6166aff1.tar.gz
freebsd-ports-gnome-6971f44eb4c66755b51b2ed9210ffefc6166aff1.tar.zst
freebsd-ports-gnome-6971f44eb4c66755b51b2ed9210ffefc6166aff1.zip
get rid of libgnugetopt dependency for -CURRENT.
configure script tests getopt_long() but does not use its result; getopt.o and getopt1.o will always be linked. So libgnugetopt dependency is just redundant.
-rw-r--r--mail/filtermail/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index c131918a7c3e..32a75388ec1b 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -10,6 +10,7 @@
PORTNAME= filtermail
PORTVERSION= 0.2.4
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://home.in.tum.de/baueran/%SUBDIR%/
@@ -20,12 +21,12 @@ MAINTAINER= harry_newton@telinco.co.uk
COMMENT= Filter mail on a pop3 server: saves downloading spam
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
- iconv:${PORTSDIR}/converters/libiconv \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt
+ iconv:${PORTSDIR}/converters/libiconv
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_GMAKE= yes
MAN1= filtermail.1
@@ -42,7 +43,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
+BROKEN= "Does not compile (bad C++ code)"
.endif
.include <bsd.port.post.mk>