aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-30 05:49:33 +0800
committeryuri <yuri@FreeBSD.org>2018-01-30 05:49:33 +0800
commit6b1512b294581a36e83395ecb163ec316cf4f7a0 (patch)
tree58a2aca4397216bedcc3b4d8e516356bfb25e89e
parent8f8f833a4dad561ed39bdcdd8f84804f66d79376 (diff)
downloadfreebsd-ports-gnome-6b1512b294581a36e83395ecb163ec316cf4f7a0.tar.gz
freebsd-ports-gnome-6b1512b294581a36e83395ecb163ec316cf4f7a0.tar.zst
freebsd-ports-gnome-6b1512b294581a36e83395ecb163ec316cf4f7a0.zip
New port: x11/wmutils-opt: Optional addons to wmutils
See details here: https://github.com/wmutils/opt PR: 225142 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14112
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wmutils-opt/Makefile24
-rw-r--r--x11/wmutils-opt/distinfo3
-rw-r--r--x11/wmutils-opt/files/patch-Makefile17
-rw-r--r--x11/wmutils-opt/files/patch-config.mk15
-rw-r--r--x11/wmutils-opt/pkg-descr5
-rw-r--r--x11/wmutils-opt/pkg-plist8
7 files changed, 73 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 6395830cecdb..407235383749 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -352,6 +352,7 @@
SUBDIR += wmdrawer
SUBDIR += wmmatrix
SUBDIR += wmutils-core
+ SUBDIR += wmutils-opt
SUBDIR += wmxss
SUBDIR += workrave
SUBDIR += x11perf
diff --git a/x11/wmutils-opt/Makefile b/x11/wmutils-opt/Makefile
new file mode 100644
index 000000000000..c46da7d060e9
--- /dev/null
+++ b/x11/wmutils-opt/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= wmutils-opt
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= x11
+
+MAINTAINER= dg@syrec.org
+COMMENT= Optional addons to wmutils
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= localbase:ldflags
+USE_XORG= xcb
+
+USE_GITHUB= yes
+GH_ACCOUNT= wmutils
+GH_PROJECT= opt
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+
+.include <bsd.port.mk>
diff --git a/x11/wmutils-opt/distinfo b/x11/wmutils-opt/distinfo
new file mode 100644
index 000000000000..2860d19187a4
--- /dev/null
+++ b/x11/wmutils-opt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515855504
+SHA256 (wmutils-opt-v1.0_GH0.tar.gz) = f30bb409bdcfa6720015dbca5356e04d4359cca3800a39948822152a94bcd055
+SIZE (wmutils-opt-v1.0_GH0.tar.gz) = 7959
diff --git a/x11/wmutils-opt/files/patch-Makefile b/x11/wmutils-opt/files/patch-Makefile
new file mode 100644
index 000000000000..b457d4e3575d
--- /dev/null
+++ b/x11/wmutils-opt/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig 2016-10-04 08:01:36 UTC
++++ Makefile
+@@ -22,12 +22,10 @@ manpages:
+ $(OBJ): $(HDR) util.o
+
+ .o:
+- @echo "LD $@"
+- @$(LD) $< -o $@ $(LDFLAGS) util.o
++ $(LD) $< -o $@ $(LDFLAGS) util.o
+
+ .c.o:
+- @echo "CC $<"
+- @$(CC) -c $< -o $@ $(CFLAGS)
++ $(CC) -c $< -o $@ $(CFLAGS)
+
+ install: $(BIN)
+ mkdir -p $(DESTDIR)$(PREFIX)/bin/
diff --git a/x11/wmutils-opt/files/patch-config.mk b/x11/wmutils-opt/files/patch-config.mk
new file mode 100644
index 000000000000..afbe953bc84f
--- /dev/null
+++ b/x11/wmutils-opt/files/patch-config.mk
@@ -0,0 +1,15 @@
+--- config.mk.orig 2016-10-04 08:01:36 UTC
++++ config.mk
+@@ -1,8 +1,8 @@
+-PREFIX = /usr
+-MANPREFIX = $(PREFIX)/share/man
++PREFIX ?= /usr/local
++MANPREFIX = $(PREFIX)/man
+
+ CC = cc
+ LD = $(CC)
+
+-CFLAGS += -std=c99 -pedantic -Wall -Os
+-LDFLAGS += -lxcb
++CFLAGS := -std=c99 -pedantic -Wall $(CFLAGS)
++LDFLAGS := -lxcb $(LDFLAGS)
diff --git a/x11/wmutils-opt/pkg-descr b/x11/wmutils-opt/pkg-descr
new file mode 100644
index 000000000000..1c7d2e88ca08
--- /dev/null
+++ b/x11/wmutils-opt/pkg-descr
@@ -0,0 +1,5 @@
+wmutils-opt is a set of optional utilities meant to accompany wmutils-core.
+This package includes tools to move/resize windows with the mouse, control
+window borders, and view a window's events and name.
+
+WWW: https://github.com/wmutils/opt
diff --git a/x11/wmutils-opt/pkg-plist b/x11/wmutils-opt/pkg-plist
new file mode 100644
index 000000000000..e7a6cefd9870
--- /dev/null
+++ b/x11/wmutils-opt/pkg-plist
@@ -0,0 +1,8 @@
+bin/chwb2
+bin/wew
+bin/wname
+bin/xmmv
+man/man1/chwb2.1.gz
+man/man1/wew.1.gz
+man/man1/wname.1.gz
+man/man1/xmmv.1.gz