aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-11-28 11:02:05 +0800
committerWen Heping <wen@FreeBSD.org>2016-11-28 11:02:05 +0800
commit6bcd3003751076632f779a834fd2f87eee81c70b (patch)
treef4fee8c36b204ad1152ed951820dc91eaee26b4b
parent98c401f0f89ea92ace4748fd8af3440dca98ebc0 (diff)
downloadfreebsd-ports-gnome-6bcd3003751076632f779a834fd2f87eee81c70b.tar.gz
freebsd-ports-gnome-6bcd3003751076632f779a834fd2f87eee81c70b.tar.zst
freebsd-ports-gnome-6bcd3003751076632f779a834fd2f87eee81c70b.zip
- Update to 4.6.0
-rw-r--r--devel/py-traits/Makefile9
-rw-r--r--devel/py-traits/distinfo5
-rw-r--r--devel/py-traits/files/patch-setup.py26
3 files changed, 12 insertions, 28 deletions
diff --git a/devel/py-traits/Makefile b/devel/py-traits/Makefile
index 91a0b0971b27..7473dadc3c78 100644
--- a/devel/py-traits/Makefile
+++ b/devel/py-traits/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= traits
-PORTVERSION= 4.5.0
+PORTVERSION= 4.6.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,11 +18,4 @@ BUILD_DEPENDS= ${PYNUMPY}
USES= python
USE_PYTHON= distutils autoplist
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-post-extract:
-# Remove traits/testing directory files are not compatible with Python 3
- cd ${WRKSRC} && ${RM} -R traits/testing/
-
.include <bsd.port.mk>
diff --git a/devel/py-traits/distinfo b/devel/py-traits/distinfo
index 30ffe8e936f4..639080bdd6ef 100644
--- a/devel/py-traits/distinfo
+++ b/devel/py-traits/distinfo
@@ -1,2 +1,3 @@
-SHA256 (traits-4.5.0.tar.gz) = 5293a8786030b0b243e059f52004355b6939d7c0f1be2eb5a605b63cca484c84
-SIZE (traits-4.5.0.tar.gz) = 4853612
+TIMESTAMP = 1480294044
+SHA256 (traits-4.6.0.tar.gz) = 5d82345e0a34b88e394964eea1be47419530027aef7f0b20ad315b6ec6c68370
+SIZE (traits-4.6.0.tar.gz) = 434937
diff --git a/devel/py-traits/files/patch-setup.py b/devel/py-traits/files/patch-setup.py
index 9a1e930a0aa6..914f1d5666aa 100644
--- a/devel/py-traits/files/patch-setup.py
+++ b/devel/py-traits/files/patch-setup.py
@@ -1,20 +1,10 @@
---- setup.py.orig 2014-05-07 10:39:42 UTC
+--- setup.py.orig 2016-11-28 02:44:17 UTC
+++ setup.py
-@@ -11,7 +11,6 @@ exec(compile(open(traits_init).read(), t
- ctraits = Extension(
- 'traits.ctraits',
- sources = ['traits/ctraits.c'],
-- extra_compile_args = ['-DNDEBUG=1', '-O3' ]#, '-DPy_LIMITED_API'],
- )
+@@ -102,7 +102,6 @@ if __name__ == "__main__":
+ ctraits = Extension(
+ 'traits.ctraits',
+ sources=['traits/ctraits.c'],
+- extra_compile_args=['-DNDEBUG=1', '-O3'],
+ )
-
-@@ -55,7 +54,8 @@ setup(
- license = 'BSD',
- maintainer = 'ETS Developers',
- maintainer_email = 'enthought-dev@enthought.com',
-- packages = find_packages(),
-+ # remove 'traits.testing*' directories not compatible with Python 3
-+ packages = find_packages(where='.', exclude=['traits.testing*']),
- platforms = ["Windows", "Linux", "Mac OS-X", "Unix", "Solaris"],
- zip_safe = False,
- use_2to3 = True,
+ def additional_commands():