aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-04-28 10:56:25 +0800
committerlioux <lioux@FreeBSD.org>2006-04-28 10:56:25 +0800
commit6bfdd7d4e58bb84482b9d70a9967b579373b1e3a (patch)
treea0a806c05fffa705f9596ead8c1f228f9fdf58b2
parent4f221507456e60aba2c8da56113c3b51f87fe4e2 (diff)
downloadfreebsd-ports-gnome-6bfdd7d4e58bb84482b9d70a9967b579373b1e3a.tar.gz
freebsd-ports-gnome-6bfdd7d4e58bb84482b9d70a9967b579373b1e3a.tar.zst
freebsd-ports-gnome-6bfdd7d4e58bb84482b9d70a9967b579373b1e3a.zip
Use ftp/wget since fetch(1) is misbehaving with these MASTER_SITES
Submitted by: pointyhat (kris)
-rw-r--r--x11/rxvt-devel/Makefile9
-rw-r--r--x11/rxvt/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index 587fc27f77df..dbe5f1fd746a 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -22,6 +22,8 @@ DISTNAME= rxvt-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= A low memory usage xterm replacement that supports color
+FETCH_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
USE_PERL5_BUILD=yes
USE_X_PREFIX= yes
USE_XPM= yes
@@ -34,6 +36,13 @@ USE_BZIP2= yes
MAN1= rxvt.1
+# fetch(1) is misbehaving with these MASTER_SITES
+FETCH_CMD= ${LOCALBASE}/bin/wget
+FETCH_REGET= 0
+DISABLE_SIZE= yes
+FETCH_BEFORE_ARGS=
+FETCH_AFTER_ARGS=
+
# disable backspace key
.if defined(WITHOUT_BACKSPACE_KEY)
CONFIGURE_ARGS+= --disable-backspace-key
diff --git a/x11/rxvt/Makefile b/x11/rxvt/Makefile
index b177ddfe830e..40af330ed0c4 100644
--- a/x11/rxvt/Makefile
+++ b/x11/rxvt/Makefile
@@ -21,6 +21,8 @@ MASTER_SITE_SUBDIR= . old devel
MAINTAINER= lioux@FreeBSD.org
COMMENT= A low memory usage xterm replacement that supports color
+FETCH_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
@@ -30,6 +32,13 @@ USE_BZIP2= yes
MAN1= rxvt.1
PLIST_FILES= bin/rxvt
+# fetch(1) is misbehaving with these MASTER_SITES
+FETCH_CMD= ${LOCALBASE}/bin/wget
+FETCH_REGET= 0
+DISABLE_SIZE= yes
+FETCH_BEFORE_ARGS=
+FETCH_AFTER_ARGS=
+
# enable big5 support
.if defined(WITH_BIG5)
CONFIGURE_ARGS+= --enable-big5