aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2011-04-06 18:34:32 +0800
committergabor <gabor@FreeBSD.org>2011-04-06 18:34:32 +0800
commit6c1bc0a8647828d54b7596e4d0ad10ccc7ece0b7 (patch)
tree24d11107aabeb837661f6ffb7932fedc008b8345
parentd4edaa101f44531310e02dba8842cdf969db5f2d (diff)
downloadfreebsd-ports-gnome-6c1bc0a8647828d54b7596e4d0ad10ccc7ece0b7.tar.gz
freebsd-ports-gnome-6c1bc0a8647828d54b7596e4d0ad10ccc7ece0b7.tar.zst
freebsd-ports-gnome-6c1bc0a8647828d54b7596e4d0ad10ccc7ece0b7.zip
- Update to 20110315
-rw-r--r--emulators/linux_dist-gentoo-stage3/Makefile4
-rw-r--r--emulators/linux_dist-gentoo-stage3/files/update.sh17
2 files changed, 19 insertions, 2 deletions
diff --git a/emulators/linux_dist-gentoo-stage3/Makefile b/emulators/linux_dist-gentoo-stage3/Makefile
index d057ab2c1947..02693df87f79 100644
--- a/emulators/linux_dist-gentoo-stage3/Makefile
+++ b/emulators/linux_dist-gentoo-stage3/Makefile
@@ -8,7 +8,7 @@ PORTNAME= gentoo-stage3
PORTVERSION= 20110315
CATEGORIES= emulators linux
MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= releases/x86/autobuilds/${PORTVERSION}
+MASTER_SITE_SUBDIR= releases/x86/autobuilds/current-stage3$-{GENTOO_OPTIMIZED}
MAINTAINER= gabor@FreeBSD.org
COMMENT= Files from Gentoo distribution, for Linux compatibility
@@ -123,7 +123,7 @@ plist:
update-port:
${MAKE} distclean
${MAKE} distclean GENTOO_OPTIMIZED=i686
- ${RM} ${DISTINFO_FILE}
+ -${RM} ${DISTINFO_FILE}
${MAKE} makesum
${MV} ${DISTINFO_FILE} ${DISTINFO_FILE}.new
${MAKE} makesum GENTOO_OPTIMIZED=i686
diff --git a/emulators/linux_dist-gentoo-stage3/files/update.sh b/emulators/linux_dist-gentoo-stage3/files/update.sh
new file mode 100644
index 000000000000..8207c1840c5c
--- /dev/null
+++ b/emulators/linux_dist-gentoo-stage3/files/update.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+#
+# This script is used for port development. Do not manually run it.
+#
+cd ${GENTOODIR}
+wget -q ftp://ftp.dei.uc.pt/pub/linux/gentoo/releases/x86/autobuilds/current-stage3-i486/ >/dev/null
+NEWVER=$(grep -o '\".*current-stage3.*"' index.html | grep 'stage3-i486-.*bz2"' | sed -e "s|.*/||g" | grep -o "2011[0-9]*")
+OLDVER=$(make -V PORTVERSION)
+rm index.html
+
+if [ ${NEWVER} -gt ${OLDVER} ]; then
+ sed -i '' "s|${OLDVER}|${NEWVER}|g" Makefile
+ make update-port
+else
+ echo "Port is up-to-date."
+fi