aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-07-10 23:46:06 +0800
committervanilla <vanilla@FreeBSD.org>2014-07-10 23:46:06 +0800
commit6c5d9f023bd2fa959d338d02898342c4e5ae0232 (patch)
treeee20778f53b4d2aab526da71493a65da5a866ea6
parentb4ba1c5c8b15cc58941857f416c70fa24351ea24 (diff)
downloadfreebsd-ports-gnome-6c5d9f023bd2fa959d338d02898342c4e5ae0232.tar.gz
freebsd-ports-gnome-6c5d9f023bd2fa959d338d02898342c4e5ae0232.tar.zst
freebsd-ports-gnome-6c5d9f023bd2fa959d338d02898342c4e5ae0232.zip
Stagify, remove unneeded define.
-rw-r--r--devel/ocaml-cppo/Makefile6
-rw-r--r--devel/ocaml-cppo/files/patch-Makefile13
2 files changed, 14 insertions, 5 deletions
diff --git a/devel/ocaml-cppo/Makefile b/devel/ocaml-cppo/Makefile
index a64bcaa3094d..cf9c5340c56d 100644
--- a/devel/ocaml-cppo/Makefile
+++ b/devel/ocaml-cppo/Makefile
@@ -7,15 +7,11 @@ CATEGORIES= devel
MASTER_SITES= http://martin.jambon.free.fr/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Simple preprocessor for OCaml
USES= gmake
USE_OCAML= yes
MAKE_JOBS_UNSAFE= yes
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/ocaml-cppo/files/patch-Makefile b/devel/ocaml-cppo/files/patch-Makefile
new file mode 100644
index 000000000000..7f04017aee0b
--- /dev/null
+++ b/devel/ocaml-cppo/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2014-07-10 23:43:16.837117715 +0800
++++ Makefile 2014-07-10 23:43:35.518127751 +0800
+@@ -33,8 +33,8 @@ opt: $(ML)
+ ocamlopt -o cppo -dtypes unix.cmxa $(ML)
+
+ install:
+- install -m 0755 cppo $(BINDIR) || \
+- install -m 0755 cppo.exe $(BINDIR)
++ install -m 0755 cppo $(DESTDIR)$(BINDIR) || \
++ install -m 0755 cppo.exe $(DESTDOR)$(BINDIR)
+
+ cppo_version.ml: Makefile
+ echo 'let cppo_version = "$(VERSION)"' > cppo_version.ml