aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-03-11 01:17:26 +0800
committerpawel <pawel@FreeBSD.org>2015-03-11 01:17:26 +0800
commit6c652deded56d021faa32de2520a5f0220c46638 (patch)
tree9e4fd0df46cf9c6f8cb39e77b56428b617d0c64e
parentebf10bbd69fbd174861c30fb6fc5daa6656a5d61 (diff)
downloadfreebsd-ports-gnome-6c652deded56d021faa32de2520a5f0220c46638.tar.gz
freebsd-ports-gnome-6c652deded56d021faa32de2520a5f0220c46638.tar.zst
freebsd-ports-gnome-6c652deded56d021faa32de2520a5f0220c46638.zip
njeqt is an attempt to build a powerful and reliable dependency injection
framework on Qt's reflection based on MOC (meta-object compiler). WWW: https://github.com/vogel/injeqt/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/injeqt/Makefile30
-rw-r--r--devel/injeqt/distinfo2
-rw-r--r--devel/injeqt/pkg-descr4
-rw-r--r--devel/injeqt/pkg-plist26
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f2d7293b7119..f124cd119057 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -897,6 +897,7 @@
SUBDIR += inilib
SUBDIR += iniparser
SUBDIR += initutil
+ SUBDIR += injeqt
SUBDIR += insight
SUBDIR += ioncube
SUBDIR += ipython
diff --git a/devel/injeqt/Makefile b/devel/injeqt/Makefile
new file mode 100644
index 000000000000..8a24734bba8b
--- /dev/null
+++ b/devel/injeqt/Makefile
@@ -0,0 +1,30 @@
+# Created by: Pawel Pekala <pawel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= injeqt
+PORTVERSION= 1.0.1
+CATEGORIES= devel
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Dependency injection framework for Qt
+
+LICENSE= LGPL21
+
+USE_GITHUB= yes
+GH_ACCOUNT= vogel
+GH_COMMIT= de36c24
+
+USES= cmake compiler:c++11-lib
+USE_QT5= buildtools_build core qmake_build
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DDISABLE_EXAMPLES:BOOL=ON \
+ -DDISABLE_TESTS:BOOL=ON
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} '/pkgconfig/ s|LIBDIR}|PREFIX}/libdata|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/devel/injeqt/distinfo b/devel/injeqt/distinfo
new file mode 100644
index 000000000000..31c98d99d186
--- /dev/null
+++ b/devel/injeqt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (injeqt-1.0.1.tar.gz) = a96b2941b53f81507a100e60df5b8dd1e7e03f5fe20ca2dfde769c288570f27d
+SIZE (injeqt-1.0.1.tar.gz) = 63750
diff --git a/devel/injeqt/pkg-descr b/devel/injeqt/pkg-descr
new file mode 100644
index 000000000000..e8d86dea4a7e
--- /dev/null
+++ b/devel/injeqt/pkg-descr
@@ -0,0 +1,4 @@
+Injeqt is an attempt to build a powerful and reliable dependency injection
+framework on Qt's reflection based on MOC (meta-object compiler).
+
+WWW: https://github.com/vogel/injeqt/
diff --git a/devel/injeqt/pkg-plist b/devel/injeqt/pkg-plist
new file mode 100644
index 000000000000..7aa2ea66e827
--- /dev/null
+++ b/devel/injeqt/pkg-plist
@@ -0,0 +1,26 @@
+include/injeqt/exception/ambiguous-types.h
+include/injeqt/exception/default-constructor-not-found.h
+include/injeqt/exception/dependency-duplicated.h
+include/injeqt/exception/dependency-on-self.h
+include/injeqt/exception/dependency-on-subtype.h
+include/injeqt/exception/dependency-on-supertype.h
+include/injeqt/exception/empty-type.h
+include/injeqt/exception/exception.h
+include/injeqt/exception/instantiation-failed.h
+include/injeqt/exception/interface-not-implemented.h
+include/injeqt/exception/invalid-dependency.h
+include/injeqt/exception/invalid-qobject.h
+include/injeqt/exception/invalid-setter.h
+include/injeqt/exception/qobject-type.h
+include/injeqt/exception/unavailable-required-types.h
+include/injeqt/exception/unique-factory-method-not-found.h
+include/injeqt/exception/unknown-type.h
+include/injeqt/exception/unresolvable-dependencies.h
+include/injeqt/injector.h
+include/injeqt/injeqt.h
+include/injeqt/module.h
+include/injeqt/type.h
+lib/libinjeqt.so
+lib/libinjeqt.so.0
+lib/libinjeqt.so.%%VERSION%%
+libdata/pkgconfig/injeqt.pc