aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-06-04 16:36:02 +0800
committeritetcu <itetcu@FreeBSD.org>2009-06-04 16:36:02 +0800
commit6d27ae4826943817497f00abe291395107425e3a (patch)
tree1b8cd5c2462791abf23f12346bb88fe825e28a9d
parenta0571558cd86b6601eabaa861c4898af3d3688b8 (diff)
downloadfreebsd-ports-gnome-6d27ae4826943817497f00abe291395107425e3a.tar.gz
freebsd-ports-gnome-6d27ae4826943817497f00abe291395107425e3a.tar.zst
freebsd-ports-gnome-6d27ae4826943817497f00abe291395107425e3a.zip
Fix build with custom PREFIX / LOCALBASE
Reported by: QATty
-rw-r--r--devel/libdfui/Makefile2
-rw-r--r--devel/libdfui/files/patch-Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/libdfui/Makefile b/devel/libdfui/Makefile
index be96757ea14a..94bcb2a92b2f 100644
--- a/devel/libdfui/Makefile
+++ b/devel/libdfui/Makefile
@@ -38,7 +38,7 @@ PORTDOCS= README
MAKE_ENV= SONAME=${SONAME} SOLINK=${SOLINK}
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${SONAME} ${PREFIX}/lib/${SONAME}
diff --git a/devel/libdfui/files/patch-Makefile b/devel/libdfui/files/patch-Makefile
index 102bccef9f77..53ac3fbf71a6 100644
--- a/devel/libdfui/files/patch-Makefile
+++ b/devel/libdfui/files/patch-Makefile
@@ -20,10 +20,10 @@
-LDFLAGS+= -L../libaura
-LDFLAGS+= -L/usr/local/lib -L/usr/pkg/lib
-LDFLAGS+= -laura
-+CFLAGS+= ${EXTRA_CFLAGS} ${WARNS} -fPIC -I%%PREFIX%%/include/aura3
++CFLAGS+= ${EXTRA_CFLAGS} ${WARNS} -fPIC -I%%LOCALBASE%%/include/aura3
+CFLAGS+= -DSMP
-+CFLAGS+= -I/usr/local/include
-+LDFLAGS+= -L/usr/local/lib
++CFLAGS+= -I%%LOCALBASE%%/include
++LDFLAGS+= -L%%LOCALBASE%%/lib
+LDFLAGS+= -laura3
# Default target: