aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-02-23 08:56:23 +0800
committermaho <maho@FreeBSD.org>2009-02-23 08:56:23 +0800
commit6d71bb21ee52a956b5a36667a05d8bae56b262eb (patch)
treea28f898f34f81b1191e3e89e420466562b4e99f4
parentb5cff840a583fd43f3f2af5ff746f40b52c64971 (diff)
downloadfreebsd-ports-gnome-6d71bb21ee52a956b5a36667a05d8bae56b262eb.tar.gz
freebsd-ports-gnome-6d71bb21ee52a956b5a36667a05d8bae56b262eb.tar.zst
freebsd-ports-gnome-6d71bb21ee52a956b5a36667a05d8bae56b262eb.zip
Add java/icedtea6-stubs.
Icedtea is part of gnu classpath project and is an implementation of the binary plugs, that Sun is unable to release under the GNUv2 license. This in combination with openjdk6 or openjdk7 makes a completely legally distributable version of Java. WWW: http://icedtea.classpath.org/wiki/Main_Page Submitted by: Brian Gardner <brian@experts-exchange.com>
-rw-r--r--java/Makefile1
-rw-r--r--java/icedtea6-stubs/Makefile33
-rw-r--r--java/icedtea6-stubs/distinfo3
-rw-r--r--java/icedtea6-stubs/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index c3518f9c8dbd..161a4333c405 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -58,6 +58,7 @@
SUBDIR += gj
SUBDIR += gnu-regexp
SUBDIR += guavac
+ SUBDIR += icedtea6-stubs
SUBDIR += infobus
SUBDIR += j2sdkee13
SUBDIR += jad
diff --git a/java/icedtea6-stubs/Makefile b/java/icedtea6-stubs/Makefile
new file mode 100644
index 000000000000..fd625df5c7ea
--- /dev/null
+++ b/java/icedtea6-stubs/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: icedtea6-stubs
+# Date created: 2009/2/21
+# Whom: Brian Gardner <brian@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icedtea6-stubs
+PORTVERSION= 1.6b
+CATEGORIES= java devel
+MASTER_SITES= http://www.intricatesoftware.com/distfiles/
+DISTNAME= jdk-7-icedtea-plugs-$(PORTVERSION)
+
+MAINTAINER= brian@experts-exchange.com
+COMMENT= IcedTea6 binary plugs for openjdk
+
+WRKSRC= $(WRKDIR)/jdk-7-icedtea-plugs
+
+USE_JAVA= yes
+JAVA_VENDOR= freebsd bsdjava
+JAVA_VERSION= 1.6
+USE_ANT= 1
+
+pre-build:
+ cd $(WRKSRC) && ${UNZIP_CMD} -u src.zip
+
+do-install:
+ $(MKDIR) -p $(JAVAJARDIR)/jdk-7-icedtea-plugs/jre/lib/
+ $(CP) $(WRKSRC)/jre/lib/rt-closed.jar $(JAVAJARDIR)/jdk-7-icedtea-plugs/jre/lib/
+
+PLIST_FILES+= %%JAVAJARDIR%%/jdk-7-icedtea-plugs/jre/lib/rt-closed.jar
+
+.include <bsd.port.mk>
diff --git a/java/icedtea6-stubs/distinfo b/java/icedtea6-stubs/distinfo
new file mode 100644
index 000000000000..194fe8b7ee09
--- /dev/null
+++ b/java/icedtea6-stubs/distinfo
@@ -0,0 +1,3 @@
+MD5 (jdk-7-icedtea-plugs-1.6b.tar.gz) = 86e575da6209157b484d0e91e41cffc8
+SHA256 (jdk-7-icedtea-plugs-1.6b.tar.gz) = 016d64416bdfe1d66901d169b2d7eaaf40a1ef00aa1d9643bf5130399619d9a0
+SIZE (jdk-7-icedtea-plugs-1.6b.tar.gz) = 49633
diff --git a/java/icedtea6-stubs/pkg-descr b/java/icedtea6-stubs/pkg-descr
new file mode 100644
index 000000000000..f37e6ed1a94a
--- /dev/null
+++ b/java/icedtea6-stubs/pkg-descr
@@ -0,0 +1,6 @@
+Icedtea is part of gnu classpath project and is an implementation
+of the binary plugs, that Sun is unable to release under the GNUv2 license.
+This in combination with openjdk6 or openjdk7 makes a completely legally
+distributable version of Java
+
+WWW: http://icedtea.classpath.org/wiki/Main_Page