aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2004-05-17 21:31:37 +0800
committererwin <erwin@FreeBSD.org>2004-05-17 21:31:37 +0800
commit6dbae72f89dd267a4fdefc38a1dcd5fee7f3b940 (patch)
tree44e87b1719561cf10ecc2d74d22d0829ae8768ea
parentfb5c8f0638385e839007117eedf852ef64a1b77d (diff)
downloadfreebsd-ports-gnome-6dbae72f89dd267a4fdefc38a1dcd5fee7f3b940.tar.gz
freebsd-ports-gnome-6dbae72f89dd267a4fdefc38a1dcd5fee7f3b940.tar.zst
freebsd-ports-gnome-6dbae72f89dd267a4fdefc38a1dcd5fee7f3b940.zip
Conditionalize dependency on DBI so this port choose the right
p5-DBI port with perl < 5.6 PR: 66735 Approved by: maintainer
-rw-r--r--mail/sympa/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index 1f42ad2d2c51..7dfc6a02cfd5 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -24,7 +24,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/Mail/Mailer.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/Locale/Msgcat.pm:${PORTSDIR}/misc/p5-Locale-Msgcat \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -82,4 +81,14 @@ post-install:
post-deinstall:
PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>