aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-29 06:08:52 +0800
committerswills <swills@FreeBSD.org>2014-09-29 06:08:52 +0800
commit6de5b606b2435d81e521c00291d6d9c461f537cf (patch)
tree28a06393d3deb70ba3cca7df9bc6126d8fcb5c0e
parent016a18d4bf6007b0a9ad1a526ab3ec8115d7a9ce (diff)
downloadfreebsd-ports-gnome-6de5b606b2435d81e521c00291d6d9c461f537cf.tar.gz
freebsd-ports-gnome-6de5b606b2435d81e521c00291d6d9c461f537cf.tar.zst
freebsd-ports-gnome-6de5b606b2435d81e521c00291d6d9c461f537cf.zip
net/syncthing: put back patch to avoid upgrading, avoid stripping
We don't want the built in upgrading, we want to do it via ports/packages, so put back the patch to make it always say the version in use is current. Avoid stripping as stripping go binaries is explicitly unsupported, dangerous and known to cause problems.
-rw-r--r--net/syncthing/Makefile3
-rw-r--r--net/syncthing/files/patch-upgrade__upgrade_supported.go10
2 files changed, 11 insertions, 2 deletions
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index b2a938d1a9fb..11464819a543 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -3,7 +3,7 @@
PORTNAME= syncthing
PORTVERSION= 0.9.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/:group1 \
https://bitbucket.org/kardianos/osext/get/:group2 \
@@ -71,7 +71,6 @@ post-patch:
do-build:
# timestamp here refers to source, not build time
cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build -ldflags "-w -X main.Version v${PORTVERSION} -X main.BuildStamp 1411588890 -X main.BuildUser ${USER} -X main.BuildHost ${HOST}" github.com/syncthing/syncthing/cmd/syncthing
- ${STRIP_CMD} ${WRKSRC}/syncthing
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/syncthing ${STAGEDIR}${PREFIX}/bin/
diff --git a/net/syncthing/files/patch-upgrade__upgrade_supported.go b/net/syncthing/files/patch-upgrade__upgrade_supported.go
new file mode 100644
index 000000000000..76c5bc7dc330
--- /dev/null
+++ b/net/syncthing/files/patch-upgrade__upgrade_supported.go
@@ -0,0 +1,10 @@
+--- upgrade/upgrade_supported.go.orig 2014-09-28 21:24:06.335428814 +0000
++++ upgrade/upgrade_supported.go 2014-09-28 21:24:59.699424791 +0000
+@@ -70,6 +70,7 @@
+
+ // Returns the latest release, including prereleases or not depending on the argument
+ func LatestRelease(prerelease bool) (Release, error) {
++ return Release{}, ErrVersionUnknown
+ resp, err := http.Get("https://api.github.com/repos/syncthing/syncthing/releases?per_page=10")
+ if err != nil {
+ return Release{}, err