aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-05-21 02:02:52 +0800
committeranholt <anholt@FreeBSD.org>2003-05-21 02:02:52 +0800
commit6e0fa1189abd5dd2be5fe6b871f576fec3f931d2 (patch)
treece6a6f29783aa72b8425f44fa23d5744d4a534bb
parent10c0a1a0d4ebcc65750b5fb97eb0aab90dd79a1c (diff)
downloadfreebsd-ports-gnome-6e0fa1189abd5dd2be5fe6b871f576fec3f931d2.tar.gz
freebsd-ports-gnome-6e0fa1189abd5dd2be5fe6b871f576fec3f931d2.tar.zst
freebsd-ports-gnome-6e0fa1189abd5dd2be5fe6b871f576fec3f931d2.zip
Add WITH_BOCHS_TERM and WITH_BOCHS_VESA options and explicitly disable MMX on
emulated processor versions that can't support it. PR: ports/52347 Submitted by: keramida (mostly)
-rw-r--r--emulators/bochs/Makefile31
1 files changed, 26 insertions, 5 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 6ccc715f37cd..32b4c895529d 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -27,7 +27,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-split-hd \
- --enable-all-optimizations
+ --enable-all-optimizations \
+ --with-x11
CFLAGS+= -fno-rtti -fno-exceptions -fomit-frame-pointer
@@ -54,6 +55,17 @@ WITH_BOCHS_CPU_LEVEL= 6
.error "WITH_BOCHS_CPU_LEVEL must be an integer value between 3 and 6."
.endif
CONFIGURE_ARGS+= --enable-cpu-level=${WITH_BOCHS_CPU_LEVEL}
+.if ${WITH_BOCHS_CPU_LEVEL} < 5
+CONFIGURE_ARGS+= --disable-mmx
+.endif
+.endif
+
+.if defined(WITH_BOCHS_TERM)
+CONFIGURE_ARGS+= --with-term
+.endif
+
+.if defined(WITH_BOCHS_VESA)
+CONFIGURE_ARGS+= --enable-vbe
.endif
.if defined(WITH_BOCHS_AMD64)
@@ -91,9 +103,6 @@ MKFONTDIR?= mkfontdir
#
pre-everything::
-.if !defined(WITH_BOCHS_CPU_LEVEL) || !defined(WITH_BOCHS_PROCESSORS) || \
- !defined(WITH_BOCHS_DEBUGGER) || !defined(WITH_BOCHS_X86_DEBUGGER) || \
- !defined(WITH_SOUND)
@${ECHO_MSG}
.if !defined(WITH_BOCHS_CPU_LEVEL)
@${ECHO_MSG} "If you want to change the processor level to emulate (default is 5, aka Pentium)"
@@ -101,6 +110,19 @@ pre-everything::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_CPU_LEVEL=<cpu level>\""
@${ECHO_MSG}
.endif
+.if !defined(WITH_BOCHS_TERM)
+ @${ECHO_MSG} "If you want to enable the plain text, console-based bochs interface"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_GUI_TERM=yes\""
+ @${ECHO_MSG}
+.endif
+.if !defined(WITH_BOCHS_VESA)
+ @${ECHO_MSG} "If you want to enable the VESA BIOS video extensions of bochs,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_VESA=yes\""
+ @${ECHO_MSG}
+.else
+ @${ECHO_MSG} "Remember that with the VESA option you must also use VGABIOS-lgpl-latest"
+ @${ECHO_MSG}
+.endif
.if !defined(WITH_BOCHS_PROCESSORS)
@${ECHO_MSG} "If you want to compile with SMP support (implies WITH_BOCHS_CPU_LEVEL=6)."
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_PROCESSORS=<number of processors>\""
@@ -131,7 +153,6 @@ pre-everything::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SOUND=yes\""
.endif
@${ECHO_MSG}
-.endif
# Post-configure
#