aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-02-01 20:54:00 +0800
committervanilla <vanilla@FreeBSD.org>2013-02-01 20:54:00 +0800
commit6e4281c76c97d8aa54852b22c1e214a6df8e0cd8 (patch)
tree6785460b08858dd6c874e481b1173542e5097de9
parent58964e9a25f2120b7f659e3c8f19598afbe499d2 (diff)
downloadfreebsd-ports-gnome-6e4281c76c97d8aa54852b22c1e214a6df8e0cd8.tar.gz
freebsd-ports-gnome-6e4281c76c97d8aa54852b22c1e214a6df8e0cd8.tar.zst
freebsd-ports-gnome-6e4281c76c97d8aa54852b22c1e214a6df8e0cd8.zip
Add py-avro 1.7.3, data serialization system for python.
PR: ports/175565 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-avro/Makefile29
-rw-r--r--devel/py-avro/distinfo2
-rw-r--r--devel/py-avro/pkg-descr13
-rw-r--r--devel/py-avro/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2505ea07aec0..c6111a414dc3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3365,6 +3365,7 @@
SUBDIR += py-aspyct
SUBDIR += py-astng
SUBDIR += py-async
+ SUBDIR += py-avro
SUBDIR += py-babel
SUBDIR += py-bison
SUBDIR += py-bitarray
diff --git a/devel/py-avro/Makefile b/devel/py-avro/Makefile
new file mode 100644
index 000000000000..b90fa91e2c4c
--- /dev/null
+++ b/devel/py-avro/Makefile
@@ -0,0 +1,29 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= avro
+PORTVERSION= 1.7.3
+CATEGORIES= devel
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= ${PORTNAME}/stable
+PKGNAMEPREFIX= py-
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Data serialization system for python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/simplejson/__init__.py:${PORTSDIR}/devel/py-simplejson
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/simplejson/__init__.py:${PORTSDIR}/devel/py-simplejson
+
+USE_PYDISTUTILS= easy_install
+USE_PYTHON= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/lang/py
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${REINPLACE_CMD} 's|@AVRO_VERSION@|${PORTVERSION}|g' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-avro/distinfo b/devel/py-avro/distinfo
new file mode 100644
index 000000000000..02b1c16efec9
--- /dev/null
+++ b/devel/py-avro/distinfo
@@ -0,0 +1,2 @@
+SHA256 (avro-src-1.7.3.tar.gz) = edf23ba0626cf648008357c7f9fb2d1e0b0eaeacce76ecd001eaa198484e9833
+SIZE (avro-src-1.7.3.tar.gz) = 1924413
diff --git a/devel/py-avro/pkg-descr b/devel/py-avro/pkg-descr
new file mode 100644
index 000000000000..fcbe3110c019
--- /dev/null
+++ b/devel/py-avro/pkg-descr
@@ -0,0 +1,13 @@
+Avro is a data serialization system.
+
+Avro provides:
+* Rich data structures.
+* A compact, fast, binary data format.
+* A container file, to store persistent data.
+* Remote procedure call (RPC).
+* Simple integration with dynamic languages. Code generation is not
+required to read or write data files nor to use or implement RPC
+protocols. Code generation as an optional optimization, only worth
+implementing for statically typed languages.
+
+WWW: http://avro.apache.org/
diff --git a/devel/py-avro/pkg-plist b/devel/py-avro/pkg-plist
new file mode 100644
index 000000000000..d8d5c301d702
--- /dev/null
+++ b/devel/py-avro/pkg-plist
@@ -0,0 +1,2 @@
+bin/avro
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%