aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-03-21 15:52:16 +0800
committerdemon <demon@FreeBSD.org>2003-03-21 15:52:16 +0800
commit6edc85776c51a3ebe672797eb202c52bbabf787d (patch)
tree4724bfcb56e1a7e87ef35577c5f2d1cd8d1d2eba
parent51cc5882a36887ea9f548921e431c5cc5c5968ec (diff)
downloadfreebsd-ports-gnome-6edc85776c51a3ebe672797eb202c52bbabf787d.tar.gz
freebsd-ports-gnome-6edc85776c51a3ebe672797eb202c52bbabf787d.tar.zst
freebsd-ports-gnome-6edc85776c51a3ebe672797eb202c52bbabf787d.zip
Unbreak.
Approved by: kris
-rw-r--r--audio/spiralsynth/Makefile2
-rw-r--r--audio/spiralsynth/files/patch-Fl_Knob.H10
2 files changed, 10 insertions, 2 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 600ba1ea9fe8..9c808e3420b8 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -14,8 +14,6 @@ DISTNAME= SpiralSynth-${PORTVERSION}
MAINTAINER= trevor@FreeBSD.org
COMMENT= MIDI-capable synthesizer for X
-BROKEN= "needs fltk 1.0.10"
-
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
diff --git a/audio/spiralsynth/files/patch-Fl_Knob.H b/audio/spiralsynth/files/patch-Fl_Knob.H
new file mode 100644
index 000000000000..7e1957f4099d
--- /dev/null
+++ b/audio/spiralsynth/files/patch-Fl_Knob.H
@@ -0,0 +1,10 @@
+--- GUI/Widgets/Fl_Knob.H.orig Wed Mar 19 13:57:41 2003
++++ GUI/Widgets/Fl_Knob.H Wed Mar 19 13:57:56 2003
+@@ -4,6 +4,7 @@
+ #define Fl_Knob_H
+ #include <FL/Fl.H>
+ #include <FL/Fl_Valuator.H>
++#include <FL/Fl_Group.H>
+
+ class Fl_Knob : public Fl_Valuator {
+ public: