aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-04-21 17:58:05 +0800
committerthierry <thierry@FreeBSD.org>2014-04-21 17:58:05 +0800
commit6eed52a178897446f82e68908a9e55be9cb9c75a (patch)
tree8ee982dd791fe9e15ef9faf908ba81192f7a20b9
parent77f996984386fc4fd36fb7dc0ea44d8d2d7a05ed (diff)
downloadfreebsd-ports-gnome-6eed52a178897446f82e68908a9e55be9cb9c75a.tar.gz
freebsd-ports-gnome-6eed52a178897446f82e68908a9e55be9cb9c75a.tar.zst
freebsd-ports-gnome-6eed52a178897446f82e68908a9e55be9cb9c75a.zip
- Support staging
- Define license - Use NOPORTEXAMPLES.
-rw-r--r--graphics/xd3d/Makefile30
-rw-r--r--graphics/xd3d/files/patch-RULES.freeBSD13
-rw-r--r--graphics/xd3d/pkg-plist106
3 files changed, 79 insertions, 70 deletions
diff --git a/graphics/xd3d/Makefile b/graphics/xd3d/Makefile
index 949d08704c66..6534c0ac3cf5 100644
--- a/graphics/xd3d/Makefile
+++ b/graphics/xd3d/Makefile
@@ -10,8 +10,9 @@ MASTER_SITES= http://www.cmap.polytechnique.fr/~jouve/xd3d/
MAINTAINER= thierry@FreeBSD.org
COMMENT= A simple scientific visualization tool
+LICENSE= GPLv2
+
#--------------------------------------------------------------------------
-NO_STAGE= yes
# You may define these options:
#
# - WITHOUT_IMAGEMAGICK : if you don't need to export bitmap images
@@ -35,7 +36,7 @@ RUN_DEPENDS+= gifsicle:${PORTSDIR}/graphics/gifsicle
MASTER_SITES_BACKUP= http://pompo.net/ports/
REINPLACE_ARGS= -i ""
-FETCH_CMD= /usr/bin/fetch
+FETCH_ARGS=
FETCH_BEFORE_ARGS= -R -o ${DISTDIR}/${DISTFILES}
USES= fortran
@@ -61,11 +62,11 @@ do-fetch:
|| ${FETCH_CMD} ${FETCH_BEFORE_ARGS} ${MASTER_SITES_BACKUP}${DISTFILES}
.endif
-post-patch:
- @${CP} ${WRKSRC}/RULES.freeBSD ${WRKSRC}/RULES
- @${REINPLACE_CMD} -e "s|%%WRKSRC%%|${WRKSRC}|" \
+pre-configure:
+ ${CP} ${WRKSRC}/RULES.freeBSD ${WRKSRC}/RULES
+ ${REINPLACE_CMD} -e "s|%%WRKSRC%%|${WRKSRC}|" \
-e "s|%%PREFIX%%|${PREFIX}|" \
- -e "s|%%X11BASE%%|${LOCALBASE}|" \
+ -e "s|%%X11BASE%%|${LOCALBASE}|" \
-e "s|%%LANG%%|${XD3D_LANG}|" \
-e "s|%%MEMORY_XD3D%%|${MEMORY_XD3D}|" \
-e "s|%%F77%%|${F77}|" \
@@ -76,15 +77,14 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${MKDIR} ${EXAMPLESDIR}
- @${CP} -Rp ${WRKSRC}/Examples/* ${EXAMPLESDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+. for FILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
+. endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -Rp ${WRKSRC}/Examples/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/xd3d/files/patch-RULES.freeBSD b/graphics/xd3d/files/patch-RULES.freeBSD
index 34b60251eba2..cdb4d360206d 100644
--- a/graphics/xd3d/files/patch-RULES.freeBSD
+++ b/graphics/xd3d/files/patch-RULES.freeBSD
@@ -1,5 +1,14 @@
---- RULES.freeBSD.orig Mon Dec 1 14:55:58 2003
-+++ RULES.freeBSD Thu Jan 29 21:43:28 2004
+--- RULES.freeBSD.orig 2005-03-14 15:22:08.000000000 +0100
++++ RULES.freeBSD 2014-04-21 11:45:00.000000000 +0200
+@@ -17,7 +17,7 @@
+ # Install directory
+ #
+ #INSTALL_DIR = /usr/local/bin
+-INSTALL_DIR = %%PREFIX%%/bin
++INSTALL_DIR = $(DESTDIR)%%PREFIX%%/bin
+
+ #
+ # Location of the X11 lib (libX11.a)
@@ -54,11 +54,11 @@
#
# Options for the Fortran compiler
diff --git a/graphics/xd3d/pkg-plist b/graphics/xd3d/pkg-plist
index fab103bc6613..7aae2dceeb8a 100644
--- a/graphics/xd3d/pkg-plist
+++ b/graphics/xd3d/pkg-plist
@@ -19,57 +19,57 @@ bin/xgraphic
%%PORTDOCS%%%%DOCSDIR%%/formats.txt
%%PORTDOCS%%%%DOCSDIR%%/xd3d_doc.pdf
%%PORTDOCS%%%%DOCSDIR%%/xgraphic_doc.pdf
-%%PORTDOCS%%%%EXAMPLESDIR%%/README_EXAMPLES
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/sinus.g
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh010
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh020
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh030
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh040
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh050
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh060
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh070
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh080
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh090
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh100
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh110
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh120
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh130
-%%PORTDOCS%%%%EXAMPLESDIR%%/Xgraphic/solh140
-%%PORTDOCS%%%%EXAMPLESDIR%%/example.c3d
-%%PORTDOCS%%%%EXAMPLESDIR%%/example.xyz
-%%PORTDOCS%%%%EXAMPLESDIR%%/example_cartesian.c3d
-%%PORTDOCS%%%%EXAMPLESDIR%%/example_cyl.c3d
-%%PORTDOCS%%%%EXAMPLESDIR%%/example_sph.c3d
-%%PORTDOCS%%%%EXAMPLESDIR%%/home.pgm
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.am
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.am_fmt
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.amdba
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.avoir2D
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/mesh3.nopo
-%%PORTDOCS%%%%EXAMPLESDIR%%/piece.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadsd.avoir2D
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadsd.depl
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadsd.eldata
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadsd.mises
-%%PORTDOCS%%%%EXAMPLESDIR%%/ref27nodes.avoir3D
-%%PORTDOCS%%%%EXAMPLESDIR%%/ref8nodes.avoir3D
-%%PORTDOCS%%%%EXAMPLESDIR%%/ref9nodes.avoir2D
-%%PORTDOCS%%%%EXAMPLESDIR%%/sphere.avoir3D
-%%PORTDOCS%%%%EXAMPLESDIR%%/sphere.depl
-%%PORTDOCS%%%%EXAMPLESDIR%%/sphere.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/spiral.xyz
-%%PORTDOCS%%%%EXAMPLESDIR%%/tetra_gmsh.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower.avoir3D
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_001.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_002.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_003.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_004.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_005.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_006.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_007.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower_008.mode
-%%PORTDOCS%%%%EXAMPLESDIR%%/tower.facext
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README_EXAMPLES
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/sinus.g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh010
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh020
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh030
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh040
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh050
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh060
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh070
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh080
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh090
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh100
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh110
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh120
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh130
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Xgraphic/solh140
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.c3d
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.xyz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_cartesian.c3d
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_cyl.c3d
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_sph.c3d
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/home.pgm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.am
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.am_fmt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.amdba
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.avoir2D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mesh3.nopo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/piece.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadsd.avoir2D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadsd.depl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadsd.eldata
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadsd.mises
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref27nodes.avoir3D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref8nodes.avoir3D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref9nodes.avoir2D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sphere.avoir3D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sphere.depl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sphere.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spiral.xyz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tetra_gmsh.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower.avoir3D
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_001.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_002.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_003.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_004.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_005.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_006.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_007.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower_008.mode
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tower.facext
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Xgraphic
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Xgraphic
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%