aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-10-02 13:36:59 +0800
committerdinoex <dinoex@FreeBSD.org>2003-10-02 13:36:59 +0800
commit6f296a1444e8e0adec63ccb6ba7f3d5fb31aeed3 (patch)
treec3f190f54be0f00e013850ebe2b430cd9419ff90
parentc83ad2d14662b2d3547d992c076412966ae20d60 (diff)
downloadfreebsd-ports-gnome-6f296a1444e8e0adec63ccb6ba7f3d5fb31aeed3.tar.gz
freebsd-ports-gnome-6f296a1444e8e0adec63ccb6ba7f3d5fb31aeed3.tar.zst
freebsd-ports-gnome-6f296a1444e8e0adec63ccb6ba7f3d5fb31aeed3.zip
- force use of PTHREAD_LIBS
-rw-r--r--net-im/licq/Makefile4
-rw-r--r--net/licq/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 9fc536e375c8..aea446e3df5d 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -25,12 +25,13 @@ LICQ_PORT?= ${.CURDIR}
# workaround for installed autoconf/automake
CONFIGURE_ARGS+=--program-transform-name=s,y,y,
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS+= ${PTHREAD_LIBS}
.if defined(WITH_SOCKS)
CONFIGURE_ARGS+=--enable-socks5
CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
.if !defined(WITHOUT_OPENSSL)
@@ -46,7 +47,6 @@ pre-configure:
${REINPLACE_CMD} -e 's=getopt.h==' \
-e 's=FLAGS -pthread=FLAGS ${PTHREAD_CFLAGS}=' \
${WRKSRC}/configure
- ${CHMOD} +x ${WRKSRC}/configure
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 9fc536e375c8..aea446e3df5d 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -25,12 +25,13 @@ LICQ_PORT?= ${.CURDIR}
# workaround for installed autoconf/automake
CONFIGURE_ARGS+=--program-transform-name=s,y,y,
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+LDFLAGS+= ${PTHREAD_LIBS}
.if defined(WITH_SOCKS)
CONFIGURE_ARGS+=--enable-socks5
CONFIGURE_ARGS+=--with-socks5-inc=${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
.if !defined(WITHOUT_OPENSSL)
@@ -46,7 +47,6 @@ pre-configure:
${REINPLACE_CMD} -e 's=getopt.h==' \
-e 's=FLAGS -pthread=FLAGS ${PTHREAD_CFLAGS}=' \
${WRKSRC}/configure
- ${CHMOD} +x ${WRKSRC}/configure
post-install:
@${CAT} ${PKGMESSAGE}