aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-09-02 00:47:28 +0800
committermakc <makc@FreeBSD.org>2010-09-02 00:47:28 +0800
commit6f2d8ff41a646c1941628b7fb3521e89319b59c8 (patch)
treeb6de2da22abdb8aa49c00b77e6f5aa252fb6f106
parent67835acd04d63f30121dbc7ca2ca213c7be480dc (diff)
downloadfreebsd-ports-gnome-6f2d8ff41a646c1941628b7fb3521e89319b59c8.tar.gz
freebsd-ports-gnome-6f2d8ff41a646c1941628b7fb3521e89319b59c8.tar.zst
freebsd-ports-gnome-6f2d8ff41a646c1941628b7fb3521e89319b59c8.zip
Update to 0.9.0
Add LICENSE PR: ports/150130 Submitted by: maintainer
-rw-r--r--security/xca/Makefile10
-rw-r--r--security/xca/distinfo6
-rw-r--r--security/xca/files/patch-doc-Makefile10
-rw-r--r--security/xca/files/patch-img-Makefile8
-rw-r--r--security/xca/pkg-plist6
5 files changed, 26 insertions, 14 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 0bb3e3c4d173..03821d57dd10 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= xca
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.9.0
CATEGORIES= security
MASTER_SITES= SF
MAINTAINER= freebsd@nagilum.org
COMMENT= Graphical certification authority
+RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
+
USE_GMAKE= yes
USE_OPENSSL= yes
USE_QT_VER= 4
@@ -25,6 +26,8 @@ CXX?= g++
MAN1= xca.1
MANCOMPRESSED= yes
+LICENSE= BSD
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
@@ -53,4 +56,7 @@ post-patch:
@echo "#define DOCDIR \"${DOCSDIR}\"" >> ${WRKSRC}/local.h
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/lib/import.cpp
+post-install:
+ @-update-mime-database ${PREFIX}/share/mime
+
.include <bsd.port.post.mk>
diff --git a/security/xca/distinfo b/security/xca/distinfo
index bee50c0628f2..9118297b9b9c 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,3 +1,3 @@
-MD5 (xca-0.8.1.tar.gz) = ca87fd1af19ea2d90ac5aca1c296dd21
-SHA256 (xca-0.8.1.tar.gz) = 3261f5899450ef8e1120a020364416424701229679d2e5b0bb9c73bed6238029
-SIZE (xca-0.8.1.tar.gz) = 598962
+MD5 (xca-0.9.0.tar.gz) = ff6e23a0aac6a6d9d10b47d3f9856f1a
+SHA256 (xca-0.9.0.tar.gz) = 6f0c9a23281752b47a2bf8ee5e56486a5eec948462bb2f3528c3a1379975432d
+SIZE (xca-0.9.0.tar.gz) = 688445
diff --git a/security/xca/files/patch-doc-Makefile b/security/xca/files/patch-doc-Makefile
index 8d39952f1ee9..7a1277b3e28e 100644
--- a/security/xca/files/patch-doc-Makefile
+++ b/security/xca/files/patch-doc-Makefile
@@ -1,5 +1,5 @@
---- doc/Makefile.orig 2009-12-10 18:44:03.000000000 +0100
-+++ doc/Makefile 2010-01-05 14:00:09.000000000 +0100
+--- doc/Makefile.orig 2010-08-29 10:28:32.000000000 +0200
++++ doc/Makefile 2010-08-30 20:52:58.000000000 +0200
@@ -4,7 +4,7 @@
DELFILES=xca*.html xca.1.gz
@@ -9,17 +9,17 @@
include $(TOPDIR)/Rules.mak
mandir=man
-@@ -13,8 +13,7 @@
- gzip -9 <$^ >$@
+@@ -14,8 +14,7 @@
xca.html: xca.sgml
+ rm -f xca*.html
- echo '<h1>No documentation generated</h1>' > $@
- $(LINUXDOC) -B html $<
+ echo 'The documentation for XCA can be viewed online at: <a href="http://xca.sourceforge.net/">http://xca.sourceforge.net/</a>.' > $@
install: xca.1.gz xca.html
install -m 755 -d $(destdir)$(docdir) \
-@@ -22,8 +21,4 @@
+@@ -23,8 +22,4 @@
install -m 644 xca*.html $(destdir)$(docdir)
install xca.1.gz $(destdir)$(prefix)/$(mandir)/man1
diff --git a/security/xca/files/patch-img-Makefile b/security/xca/files/patch-img-Makefile
index a4c52ac5f338..7bfdb16583f7 100644
--- a/security/xca/files/patch-img-Makefile
+++ b/security/xca/files/patch-img-Makefile
@@ -1,11 +1,11 @@
---- img/Makefile.orig 2009-12-10 18:44:03.000000000 +0100
-+++ img/Makefile 2010-01-05 12:25:31.000000000 +0100
+--- img/Makefile.orig 2010-08-29 10:28:32.000000000 +0200
++++ img/Makefile 2010-08-30 20:57:04.000000000 +0200
@@ -15,7 +15,7 @@
echo $(OBJS)
install:
-- install -D -m 644 key.xpm $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
-+ install -d -m 755 $(destdir)$(prefix)/share/pixmaps && install -m 644 key.xpm $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
+- install -D -m 644 xca-32x32.xpm $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
++ install -d -m 755 $(destdir)$(prefix)/share/pixmaps && install -m 644 xca-32x32.xpm $(destdir)$(prefix)/share/pixmaps/xca-32x32.xpm
imgres.cpp: imgres.rcc
$(RCC) -o $@ $<
diff --git a/security/xca/pkg-plist b/security/xca/pkg-plist
index c9142374e3e8..c1cf78e9d5d0 100644
--- a/security/xca/pkg-plist
+++ b/security/xca/pkg-plist
@@ -9,9 +9,15 @@ bin/xca
%%DATADIR%%/oids.txt
%%DATADIR%%/xca_de.qm
%%DATADIR%%/xca_es.qm
+%%DATADIR%%/xca_ru.qm
%%DOCSDIR%%/xca.html
share/applications/xca.desktop
+share/mime/packages/xca.xml
share/pixmaps/xca-32x32.xpm
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
@dirrmtry share/applications
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true