aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2007-12-20 00:30:28 +0800
committerobrien <obrien@FreeBSD.org>2007-12-20 00:30:28 +0800
commit6f5686affe63d5f4f2b17e10a61ad624c2205d76 (patch)
tree7c35e6a85f4db37473706e5d3c023ef433a53c95
parent3aed4e2dab9596467c436790181fc835e7771c3b (diff)
downloadfreebsd-ports-gnome-6f5686affe63d5f4f2b17e10a61ad624c2205d76.tar.gz
freebsd-ports-gnome-6f5686affe63d5f4f2b17e10a61ad624c2205d76.tar.zst
freebsd-ports-gnome-6f5686affe63d5f4f2b17e10a61ad624c2205d76.zip
Re-enable WITH_TCL.
+ fixed TCL_DEFS processing in patch-configure + re-enabled Tcl support (using new bsd.tcl.mk) + supports Tcl 80, 82, 83, 84, 85 (WITH_TCL_VER=8x or VIM_WITH_TCL_VER=8x) + no support for threaded Tcl yet (because of the way how vim's configure searches for Tcl, this needs more modifications) PR: 112347 Submitted by: mm
-rw-r--r--editors/vim/Makefile15
-rw-r--r--editors/vim/files/patch-configure2
2 files changed, 8 insertions, 9 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 0c24e44d287c..9443b06dcf68 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -56,7 +56,7 @@ MANLANG= "" ru.KOI8-R ru.UTF-8 pl.ISO8859-2 pl.UTF-8 pl fr.ISO8859-1 \
fr.UTF-8 fr it.ISO8859-1 it.UTF-8 it
.if defined(PACKAGE_BUILDING) && !defined(LITE)
-#WITH_TCL= yes
+WITH_TCL= yes
WITH_PERL= yes
WITH_PYTHON= yes
WITH_CSCOPE= yes
@@ -64,10 +64,6 @@ WITH_EXUBERANT_CTAGS=yes
WITH_LANG= yes
.endif
-.if defined(WITH_TCL)
-BROKEN= Does not compile
-.endif
-
.if defined(WITH_PYTHON)
USE_PYTHON= yes
MAKE_ARGS+= CONF_OPT_PYTHON="--enable-pythoninterp"
@@ -78,6 +74,11 @@ USE_RUBY= yes
MAKE_ARGS+= CONF_OPT_RUBY="--enable-rubyinterp"
.endif
+.if defined(WITH_TCL)
+USE_TCL= 80+
+USE_TCL_NO_THREADS= yes
+.endif
+
.if defined(WITH_PERL)
WANT_PERL= yes
.endif
@@ -111,9 +112,7 @@ MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp"
.endif
.if defined(WITH_TCL)
-BUILD_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
-LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
-MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp"
+MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp --with-tclsh="${TCLSH:S/${LOCALBASE}\/bin\///g}""
.endif
.if !defined(WITHOUT_X11)
diff --git a/editors/vim/files/patch-configure b/editors/vim/files/patch-configure
index c368a63bbdfc..276eb1ce3dc4 100644
--- a/editors/vim/files/patch-configure
+++ b/editors/vim/files/patch-configure
@@ -3,6 +3,6 @@
@@ -4644,3 +4644,4 @@ echo "${ECHO_T}$try/tclConfig.sh" >&6
TCL_LIBS=`eval echo "$TCL_LIB_SPEC $TCL_LIBS"`
- TCL_DEFS=`echo $TCL_DEFS | sed -e 's/\\\\ /\\\\X/g' | tr ' ' '\012' | sed -e '/^-[^D]/d' -e '/-D[^_]/d' -e 's/-D_/ -D_/' | tr '\012' ' ' | sed -e 's/\\\\X/\\\\ /g'`
-+ TCL_DEFS=`echo $TCL_DEFS | tr ' ' '\012' | sed -e 's/\\\\ /\\\\X/g' -e '/^-[^D]/d' -e '/-D[^_]/d' -e 's/-D_/ -D_/' | tr '\012' ' ' | sed -e 's/\\\\X/\\\\ /g'`
++ TCL_DEFS=`echo $TCL_DEFS | sed -e 's/\\ /\\\\X/g' | tr ' ' '\012' | sed -e '/^-[^D]/d' -e '/-D[^_]/d' -e 's/-D_/ -D_/' | tr '\012' ' ' | sed -e 's/\\\\X/\\ /g'`
+
break