aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-08-14 05:26:26 +0800
committerrm <rm@FreeBSD.org>2015-08-14 05:26:26 +0800
commit70129898974c6c27eef1835faaac0d5b9e811bf0 (patch)
tree3c349723c89df3e38dfe478484b7dd9b28a0fa83
parenta4af020b9f05c9ddd0d02856deaad972190a61e8 (diff)
downloadfreebsd-ports-gnome-70129898974c6c27eef1835faaac0d5b9e811bf0.tar.gz
freebsd-ports-gnome-70129898974c6c27eef1835faaac0d5b9e811bf0.tar.zst
freebsd-ports-gnome-70129898974c6c27eef1835faaac0d5b9e811bf0.zip
devel/py-grab: update to 0.6.21
-rw-r--r--devel/py-grab/Makefile11
-rw-r--r--devel/py-grab/distinfo4
-rw-r--r--devel/py-grab/pkg-descr19
3 files changed, 25 insertions, 9 deletions
diff --git a/devel/py-grab/Makefile b/devel/py-grab/Makefile
index 789a3940ac47..2f2469fe54fc 100644
--- a/devel/py-grab/Makefile
+++ b/devel/py-grab/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= grab
-PORTVERSION= 0.5.5
+PORTVERSION= 0.6.21
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +11,16 @@ COMMENT= Site scraping framework
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}curl>0:${PORTSDIR}/ftp/py-curl
+ ${PYTHON_PKGNAMEPREFIX}curl>0:${PORTSDIR}/ftp/py-curl \
+ ${PYTHON_PKGNAMEPREFIX}weblib>0:${PORTSDIR}/devel/py-weblib \
+ ${PYTHON_PKGNAMEPREFIX}selection>0:${PORTSDIR}/devel/py-selection
+NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
+post-extract:
+ ${RM} -rf ${WRKSRC}/test
+
.include <bsd.port.mk>
diff --git a/devel/py-grab/distinfo b/devel/py-grab/distinfo
index 34c2aaa76008..c3493e8a1c68 100644
--- a/devel/py-grab/distinfo
+++ b/devel/py-grab/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grab-0.5.5.tar.gz) = e14a5e110d1d1e4b42d9c25a6075f83bcff4daf2ea3acbfa773467e61f6e45f6
-SIZE (grab-0.5.5.tar.gz) = 161432
+SHA256 (grab-0.6.21.tar.gz) = cad55287c0da16b2e303ba27a4d77a2905c1ac3e73badb83d3d143b0fe701e99
+SIZE (grab-0.6.21.tar.gz) = 89728
diff --git a/devel/py-grab/pkg-descr b/devel/py-grab/pkg-descr
index 5c31cefb4643..70d64ce18609 100644
--- a/devel/py-grab/pkg-descr
+++ b/devel/py-grab/pkg-descr
@@ -1,7 +1,18 @@
-Grab is site scraping framework. Grab could be used for:
+Grab is a python web scraping framework. Grab provides tons of helpful methods
+to scrape web sites and to process the scraped content:
- - website data mining
- - work with network API
- - automation of actions performed on websites
+ * Automatic cookies (session) support
+ * HTTP and SOCKS proxy with and without authorization
+ * Keep-Alive support
+ * IDN support
+ * Tools to work with web forms
+ * Easy multipart file uploading
+ * Flexible customization of HTTP requests
+ * Automatic charset detection
+ * Powerful API of extracting info from HTML documents with XPATH queries
+ * Asynchronous API to make thousands of simultaneous queries. This part of
+ library called Spider and it is too big to even list its features in this
+ README.
+ * Python 3 ready
WWW: http://grablib.org/