aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-10-02 10:51:55 +0800
committermarino <marino@FreeBSD.org>2016-10-02 10:51:55 +0800
commit702ab00e799042bc58b59f8017e00a30374c4761 (patch)
tree38f829f5179c075080871b3cf09c29e3e30c26e4
parent8902f66e54ef2dcd3ba867bef7fac06d57a7f0e6 (diff)
downloadfreebsd-ports-gnome-702ab00e799042bc58b59f8017e00a30374c4761.tar.gz
freebsd-ports-gnome-702ab00e799042bc58b59f8017e00a30374c4761.tar.zst
freebsd-ports-gnome-702ab00e799042bc58b59f8017e00a30374c4761.zip
databases/mariadb101: Fix stage-QA for client
THere were 5 new programs built and installed by both the client and the server. This is not a unique case. Previously they were allocated to the client and removed by the post-install target of the server. In this case, they've already been allocated to the server, so we need a new post-install target for the client to remove them from the stage directory so stage-QA checks pass. While here, remove the now-unnecessary DragonFly configure argument and change the backtick in a comment to an apostrophe to avoid the makefile being interpreted as a shell script by some editors. Also remove redundant forward slashes on the server post-install target. Approved by: just-fix-it
-rw-r--r--databases/mariadb101-server/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 629455f9c7c0..d3412344fd4d 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -87,7 +87,7 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
DATADIR= ${PREFIX}/share/mysql
.ifdef USE_MYSQL
-.error You have `USE_MYSQL' variable defined either in environment or in make(1) arguments. This leads to a circular dependency. Please undefine and try again.
+.error You have 'USE_MYSQL' variable defined either in environment or in make(1) arguments. This leads to a circular dependency. Please undefine and try again.
.endif
CONFLICTS_INSTALL= mariadb5*-${PKGNAMESUFFIX:C/^[0-9]*-//}-* \
@@ -102,6 +102,9 @@ OPTIONS_SUB= yes
# MySQL-Client part
USES+= readline
GSSAPI_NONE_CMAKE_ON= -DPLUGIN_AUTH_GSSAPI_CLIENT=NO
+
+post-install:
+ ${RM} ${STAGEDIR}${PREFIX}/bin/wsrep*
.else
# MySQL-Server part
USES+= mysql:101m
@@ -140,8 +143,8 @@ post-install:
${STAGEDIR}${PREFIX}/bin/mysql_config \
${STAGEDIR}${PREFIX}/bin/mysql_find_rows \
${STAGEDIR}${PREFIX}/bin/mysqlaccess
- ${RM} -r ${STAGEDIR}/${PREFIX}/share/mysql/policy \
- ${STAGEDIR}/${PREFIX}/share/pkgconfig
+ ${RM} -r ${STAGEDIR}${PREFIX}/share/mysql/policy \
+ ${STAGEDIR}${PREFIX}/share/pkgconfig
.endif # defined(CLIENT_ONLY)
.include <bsd.port.pre.mk>
@@ -150,10 +153,6 @@ post-install:
IGNORE= BASE_GSSAPI is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
.endif
-.if ${OPSYS} == DragonFly
-CMAKE_ARGS+= -DWITHOUT_TOKUDB
-.endif
-
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} >= 1000012
CMAKE_ARGS+= -DWITH_JEMALLOC="system"