aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2014-09-17 00:20:26 +0800
committerskreuzer <skreuzer@FreeBSD.org>2014-09-17 00:20:26 +0800
commit70a3a7602d7ce5b488f8c8a0602ecce50d95fb8c (patch)
tree0ce83477f28a056fda4f73948f86db1ef70587f7
parent22ae3629ccc7977d050bb084bf9383e45681b266 (diff)
downloadfreebsd-ports-gnome-70a3a7602d7ce5b488f8c8a0602ecce50d95fb8c.tar.gz
freebsd-ports-gnome-70a3a7602d7ce5b488f8c8a0602ecce50d95fb8c.tar.zst
freebsd-ports-gnome-70a3a7602d7ce5b488f8c8a0602ecce50d95fb8c.zip
Simple API access to Google Spreadsheets
WWW: http://burnash.github.io/gspread/
-rw-r--r--net/Makefile1
-rw-r--r--net/py-gspread/Makefile18
-rw-r--r--net/py-gspread/distinfo2
-rw-r--r--net/py-gspread/pkg-descr3
4 files changed, 24 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 741b27860efb..f1b5e44af705 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -864,6 +864,7 @@
SUBDIR += py-eventlet
SUBDIR += py-gntp
SUBDIR += py-google
+ SUBDIR += py-gspread
SUBDIR += py-gspreadsheet
SUBDIR += py-impacket
SUBDIR += py-ipaddress
diff --git a/net/py-gspread/Makefile b/net/py-gspread/Makefile
new file mode 100644
index 000000000000..154ac8d768cd
--- /dev/null
+++ b/net/py-gspread/Makefile
@@ -0,0 +1,18 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gspread
+PORTVERSION= 0.2.2
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Google Spreadsheets Python API
+
+LICENSE= MIT
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/net/py-gspread/distinfo b/net/py-gspread/distinfo
new file mode 100644
index 000000000000..55a2a3833e12
--- /dev/null
+++ b/net/py-gspread/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gspread-0.2.2.tar.gz) = 544750dacd4d6fec5279e6b988841e078b6ea687a1889cb451b28a903874eab3
+SIZE (gspread-0.2.2.tar.gz) = 14219
diff --git a/net/py-gspread/pkg-descr b/net/py-gspread/pkg-descr
new file mode 100644
index 000000000000..d1dd41cd67cf
--- /dev/null
+++ b/net/py-gspread/pkg-descr
@@ -0,0 +1,3 @@
+Simple API access to Google Spreadsheets
+
+WWW: http://burnash.github.io/gspread/