aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-05-31 08:00:14 +0800
committersylvio <sylvio@FreeBSD.org>2010-05-31 08:00:14 +0800
commit71698f682f21072a2cf13f7666bfeee4c5b6769a (patch)
tree157705a691ddbb7b6e239a48120a40dca4551e37
parent53fbfe8ee7d3310d0a04b563c977a4018b0bf406 (diff)
downloadfreebsd-ports-gnome-71698f682f21072a2cf13f7666bfeee4c5b6769a.tar.gz
freebsd-ports-gnome-71698f682f21072a2cf13f7666bfeee4c5b6769a.tar.zst
freebsd-ports-gnome-71698f682f21072a2cf13f7666bfeee4c5b6769a.zip
- Squid 3.1 uses g++ to compile the configuration test programs. This
causes two tests (for setresuid(2) and strnstr(3)) to fail due to g++ complaining about programming errors within the tests itself. These tests do work on earlier versions of Squid where gcc is used to compile them. - Add a patch to correct these issues - BUMP PORTREVISION PR: ports/147219 Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer)
-rw-r--r--www/squid31/Makefile3
-rw-r--r--www/squid31/files/patch-configure23
2 files changed, 25 insertions, 1 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 68e7247c0524..38423c1a2710 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -53,6 +53,7 @@
PORTNAME= squid
PORTVERSION= 3.1.${SQUID_STABLE_VER}
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
http://mirrors.ccs.neu.edu/Squid/ \
@@ -74,6 +75,7 @@ MASTER_SITE_SUBDIR= squid
DISTNAME= squid-3.1.${SQUID_STABLE_VER}
DIST_SUBDIR= squid3.1
+PATCHFILES=
PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www2.us.squid-cache.org/%SUBDIR%/ \
http://www1.at.squid-cache.org/%SUBDIR%/ \
@@ -83,7 +85,6 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www2.tw.squid-cache.org/%SUBDIR%/
PATCH_SITE_SUBDIR= Versions/v3/3.1/changesets
-PATCHFILES=
MAINTAINER= tmseck@web.de
COMMENT= HTTP Caching Proxy
diff --git a/www/squid31/files/patch-configure b/www/squid31/files/patch-configure
new file mode 100644
index 000000000000..2452bff4e81c
--- /dev/null
+++ b/www/squid31/files/patch-configure
@@ -0,0 +1,23 @@
+Correct two configure tests that fail whenn g++ is used instead of gcc.
+--- configure.orig 2010-05-30 16:00:03.000000000 +0200
++++ configure 2010-05-30 16:00:33.000000000 +0200
+@@ -48547,7 +48547,10 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+
++#include <sys/types.h> /* for setresuid(2) on FreeBSD */
++#include <stdio.h> /* for perror(3) on FreeBSD */
+ #include <stdlib.h>
++#include <unistd.h> /* for setresuid(2) on FreeBSD */
+ int main(int argc, char **argv) {
+ if(setresuid(-1,-1,-1)) {
+ perror("setresuid:");
+@@ -48632,7 +48635,7 @@
+ int main(int argc, char **argv)
+ {
+ int size = 20;
+- char *str = malloc(size);
++ char *str = (char *)malloc(size);
+ memset(str, 'x', size);
+ strnstr(str, "fubar", size);
+ return 0;