aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-19 23:52:28 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-19 23:52:28 +0800
commit724a16d387f7287efd44e84f0600dec58ba69d4b (patch)
tree5032d0eeff6fcbc205bec198be95fe9d57ae75b1
parent4c278fb472c80c51ba0d2e6e82cfa8316c4a1e30 (diff)
downloadfreebsd-ports-gnome-724a16d387f7287efd44e84f0600dec58ba69d4b.tar.gz
freebsd-ports-gnome-724a16d387f7287efd44e84f0600dec58ba69d4b.tar.zst
freebsd-ports-gnome-724a16d387f7287efd44e84f0600dec58ba69d4b.zip
Stagify.
Approved by: portmgr@
-rw-r--r--misc/loop/Makefile5
-rw-r--r--misc/loop/files/patch-Makefile15
2 files changed, 13 insertions, 7 deletions
diff --git a/misc/loop/Makefile b/misc/loop/Makefile
index c20b58fa0cee..d33d145ab9bc 100644
--- a/misc/loop/Makefile
+++ b/misc/loop/Makefile
@@ -9,9 +9,6 @@ MASTER_SITES= http://www.nesbitt.ca/downloads/loop/
MAINTAINER= freebsd@nesbitt.ca
COMMENT= Prints to stdout a series of numbers from `start' to `end'
-MAN1= loop.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/loop
+PLIST_FILES= bin/loop man/man1/loop.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/misc/loop/files/patch-Makefile b/misc/loop/files/patch-Makefile
index 419b416632e0..e36c1e4e1cd8 100644
--- a/misc/loop/files/patch-Makefile
+++ b/misc/loop/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Nov 2 01:23:17 2005
-+++ Makefile Wed Nov 2 01:18:17 2005
+--- Makefile.orig 2005-11-02 16:44:21.000000000 +0800
++++ Makefile 2014-06-19 23:50:39.847155161 +0800
@@ -1,7 +1,7 @@
-CC = gcc
@@ -7,7 +7,16 @@
-DESTDIR = /usr/local
+CC ?= gcc
+CFLAGS += -Wall
-+DESTDIR = ${PREFIX}
++#DESTDIR = ${PREFIX}
loop:
${CC} ${CFLAGS} -o loop loop.c
+@@ -17,6 +17,6 @@ clean:
+ rm -f loop loop.1.gz
+
+ install: loop man
+- install loop ${DESTDIR}/bin
+- install loop.1.gz $(DESTDIR)/man/man1
++ install loop $(DESTDIR)${PREFIX}/bin
++ install loop.1.gz $(DESTDIR)${PREFIX}/man/man1
+