aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-06-07 03:49:42 +0800
committerpav <pav@FreeBSD.org>2005-06-07 03:49:42 +0800
commit72573ae29955073044baa44c8aa552ef68012b93 (patch)
tree6b9e2f43cff46812926407086ec9e83eaa743866
parent7660f3f64a1d68c8aca64c10fe34aa67e853f95b (diff)
downloadfreebsd-ports-gnome-72573ae29955073044baa44c8aa552ef68012b93.tar.gz
freebsd-ports-gnome-72573ae29955073044baa44c8aa552ef68012b93.tar.zst
freebsd-ports-gnome-72573ae29955073044baa44c8aa552ef68012b93.zip
Net_UserAgent_Mobile parses HTTP_USER_AGENT strings of (mainly Japanese)
mobile HTTP user agents. It'll be useful in page dispatching by user agents. This package was ported from Perl's HTTP::MobileAgent. PR: ports/81936 Submitted by: Shinsuke Matsui <smatsui@karashi.org>
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_UserAgent_Mobile/Makefile30
-rw-r--r--net/pear-Net_UserAgent_Mobile/distinfo2
-rw-r--r--net/pear-Net_UserAgent_Mobile/pkg-descr8
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2a880a3b1579..11e56408df57 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -586,6 +586,7 @@
SUBDIR += pear-Net_Socket
SUBDIR += pear-Net_URL
SUBDIR += pear-Net_UserAgent_Detect
+ SUBDIR += pear-Net_UserAgent_Mobile
SUBDIR += pear-SOAP
SUBDIR += pebrot
SUBDIR += pecl-radius
diff --git a/net/pear-Net_UserAgent_Mobile/Makefile b/net/pear-Net_UserAgent_Mobile/Makefile
new file mode 100644
index 000000000000..4cf6516a7995
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Net_UserAgent_Mobile
+# Date created: 06 June 2005
+# Whom: Shinsuke Matsui (<smatsui@karashi.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_UserAgent_Mobile
+PORTVERSION= 0.23.0
+CATEGORIES= net www pear
+
+MAINTAINER= smatsui@karashi.org
+COMMENT= PEAR class that parses HTTP mobile user agent string
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net/UserAgent
+FILES= Mobile.php Mobile/AirHPhone.php Mobile/Common.php \
+ Mobile/Display.php Mobile/DoCoMo.php Mobile/DoCoMoDisplayMap.php \
+ Mobile/EZweb.php Mobile/Vodafone.php Mobile/NonMobile.php \
+ Mobile/Request.php
+TESTS= 00-compile.phpt 01-request.phpt 02-docomo.phpt \
+ 03-jphone.phpt 04-ezweb.phpt 05-display.phpt \
+ 06-nonmobile.phpt 07-airhphone.phpt 08-display-xmlmap.phpt \
+ DoCoMoMap.xml
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_UserAgent_Mobile/distinfo b/net/pear-Net_UserAgent_Mobile/distinfo
new file mode 100644
index 000000000000..0996b583b69c
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_UserAgent_Mobile-0.23.0.tgz) = 10620f2ab7c847579341365ee95aa8a7
+SIZE (PEAR/Net_UserAgent_Mobile-0.23.0.tgz) = 28278
diff --git a/net/pear-Net_UserAgent_Mobile/pkg-descr b/net/pear-Net_UserAgent_Mobile/pkg-descr
new file mode 100644
index 000000000000..8ee993c31fdd
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/pkg-descr
@@ -0,0 +1,8 @@
+Net_UserAgent_Mobile parses HTTP_USER_AGENT strings of (mainly Japanese)
+mobile HTTP user agents. It'll be useful in page dispatching by user agents.
+This package was ported from Perl's HTTP::MobileAgent.
+See http://search.cpan.org/search?mode=module&query=HTTP-MobileAgent
+The author of the HTTP::MobileAgent module is
+Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+
+WWW: http://pear.php.net/package/Net_UserAgent_Mobile/