aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-03-21 00:12:11 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 20:02:37 +0800
commit727fac8d1b7d014b1b686b2b43287d3905cc0c52 (patch)
treebb67245a8a29bebd42eeb204f3c2d5adabb4810d
parent05f0ef7669234821a3756e1ed94292e4ea168902 (diff)
downloadfreebsd-ports-gnome-727fac8d1b7d014b1b686b2b43287d3905cc0c52.tar.gz
freebsd-ports-gnome-727fac8d1b7d014b1b686b2b43287d3905cc0c52.tar.zst
freebsd-ports-gnome-727fac8d1b7d014b1b686b2b43287d3905cc0c52.zip
New port: graphics/py-scikit-image
Image processing SciKit (Toolbox for SciPy) WWW: http://scikit-image.org/ PR: 217427 Submitted by: eric@camachat.org (maintainer) Reviewed by: mat Approved by: swills (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10053
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-scikit-image/Makefile46
-rw-r--r--graphics/py-scikit-image/distinfo3
-rw-r--r--graphics/py-scikit-image/pkg-descr4
4 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7a2f21ab4253..3d8827f6f9e1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -883,6 +883,7 @@
SUBDIR += py-qt5-svg
SUBDIR += py-rabbyt
SUBDIR += py-sane
+ SUBDIR += py-scikit-image
SUBDIR += py-seqdiag
SUBDIR += py-sorl-thumbnail
SUBDIR += py-soya3d
diff --git a/graphics/py-scikit-image/Makefile b/graphics/py-scikit-image/Makefile
new file mode 100644
index 000000000000..81ddcc743255
--- /dev/null
+++ b/graphics/py-scikit-image/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= scikit-image
+PORTVERSION= 0.12.3
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= eric@camachat.org
+COMMENT= Image Processing SciKit (Toolbox for SciPy)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${LOCALBASE}/bin/cython:lang/cython \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.9:science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}numpydoc>=0.6:textproc/py-numpydoc
+RUN_DEPENDS= ${PYNUMPY} \
+ ${LOCALBASE}/bin/cython:lang/cython \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.9:science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}numpydoc>=0.6:textproc/py-numpydoc \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=1.7:graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=1.8:math/py-networkx \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.1:math/py-matplotlib \
+ ${PYTHON_PKGNAMEPREFIX}PyWavelets>=0.4:math/py-PyWavelets
+
+USES= cpe python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+PYDISTUTILS_BUILD_TARGET= build build_ext
+PYDISTUTILS_BUILDARGS+= saveopts
+
+post-install:
+ @${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/skimage -name "*.so" -exec ${STRIP_CMD} {} \;
+
+do-test:
+ @cd ${WRKSRC} && \
+ ${PYTHON_CMD} ${PYSETUP} build_ext -i && \
+ ${PYTHON_CMD} selftest.py && \
+ ${PYTHON_CMD} -m nose -vx Tests/test_*.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-scikit-image/distinfo b/graphics/py-scikit-image/distinfo
new file mode 100644
index 000000000000..79d8913fd5c0
--- /dev/null
+++ b/graphics/py-scikit-image/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489879947
+SHA256 (scikit-image-scikit-image-v0.12.3_GH0.tar.gz) = 4356124bc4c258ddcb84ffbf3b8cec7034d20cb8da267ff881aae0668a2e0caa
+SIZE (scikit-image-scikit-image-v0.12.3_GH0.tar.gz) = 16763030
diff --git a/graphics/py-scikit-image/pkg-descr b/graphics/py-scikit-image/pkg-descr
new file mode 100644
index 000000000000..7639213c2c07
--- /dev/null
+++ b/graphics/py-scikit-image/pkg-descr
@@ -0,0 +1,4 @@
+scikit-image is a collection of algorithms for image processing. It is
+available free of charge and free of restriction. We pride ourselves on
+high-quality, peer-reviewed code, written by an active community of
+volunteers.