aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-02-19 16:33:06 +0800
committermarcus <marcus@FreeBSD.org>2003-02-19 16:33:06 +0800
commit72d10b60107401f79e844c290702fc3bbc928f40 (patch)
tree35c1efc06bae1517043481e0ad72cd09cbed7ff6
parent26f6e25ef77c93117bf44a1fe7ba9fc12eab0172 (diff)
downloadfreebsd-ports-gnome-72d10b60107401f79e844c290702fc3bbc928f40.tar.gz
freebsd-ports-gnome-72d10b60107401f79e844c290702fc3bbc928f40.tar.zst
freebsd-ports-gnome-72d10b60107401f79e844c290702fc3bbc928f40.zip
Correct PLIST_SUB so one plug-in doesn't overwrite the other's
substitutions. PR: 48451 Submitted by: alane
-rw-r--r--irc/xchat-gnome/Makefile8
-rw-r--r--irc/xchat2/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 0d2bcf156659..ed9f02c89e75 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -43,10 +43,10 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_PYTHON)
USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-python
-PLIST_SUB= PYTHON=""
+PLIST_SUB+= PYTHON=""
.else
CONFIGURE_ARGS+= --disable-python
-PLIST_SUB= PYTHON="@comment "
+PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_TCL)
@@ -56,10 +56,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include/tcl8.3" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-L${LOCALBASE}/lib/tcl8.3"
-PLIST_SUB= TCL=""
+PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+= --enable-tcl=no
-PLIST_SUB= TCL="@comment "
+PLIST_SUB+= TCL="@comment "
.endif
pre-everything::
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 0d2bcf156659..ed9f02c89e75 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -43,10 +43,10 @@ CONFIGURE_ARGS+= --enable-socks
.if defined(WITH_PYTHON)
USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-python
-PLIST_SUB= PYTHON=""
+PLIST_SUB+= PYTHON=""
.else
CONFIGURE_ARGS+= --disable-python
-PLIST_SUB= PYTHON="@comment "
+PLIST_SUB+= PYTHON="@comment "
.endif
.if defined(WITH_TCL)
@@ -56,10 +56,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include/tcl8.3" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-L${LOCALBASE}/lib/tcl8.3"
-PLIST_SUB= TCL=""
+PLIST_SUB+= TCL=""
.else
CONFIGURE_ARGS+= --enable-tcl=no
-PLIST_SUB= TCL="@comment "
+PLIST_SUB+= TCL="@comment "
.endif
pre-everything::