aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-09-25 19:39:45 +0800
committertg <tg@FreeBSD.org>2001-09-25 19:39:45 +0800
commit74200bcdc2732b46da6cf917efd15489d85964dd (patch)
tree5dbfa0a8f6156623253a87c887efee376b279ac6
parent03e122c171a12832e35e94e43a3dd1d766188508 (diff)
downloadfreebsd-ports-gnome-74200bcdc2732b46da6cf917efd15489d85964dd.tar.gz
freebsd-ports-gnome-74200bcdc2732b46da6cf917efd15489d85964dd.tar.zst
freebsd-ports-gnome-74200bcdc2732b46da6cf917efd15489d85964dd.zip
Depend on math/libgmp when running a recent -current.
-rw-r--r--lang/python-devel/Makefile6
-rw-r--r--lang/python/Makefile6
-rw-r--r--lang/python21/Makefile6
-rw-r--r--lang/python22/Makefile6
-rw-r--r--lang/python23/Makefile6
-rw-r--r--lang/python24/Makefile6
-rw-r--r--lang/python25/Makefile6
-rw-r--r--lang/python26/Makefile6
-rw-r--r--lang/python27/Makefile6
-rw-r--r--lang/python30/Makefile6
-rw-r--r--lang/python31/Makefile6
-rw-r--r--lang/python32/Makefile6
12 files changed, 72 insertions, 0 deletions
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python/Makefile b/lang/python/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index b17756041bf6..b548510597d6 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -49,6 +49,12 @@ CFLAGS+= -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
+.if ${OSVERSION} > 500023
+LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif