aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2018-04-26 21:49:09 +0800
committerjrm <jrm@FreeBSD.org>2018-04-26 21:49:09 +0800
commit7477e7f4cda11699165d7dfcb42b11944b2f7ef7 (patch)
tree73629039cb72c8ced6cd6de0e02f47febecd00a6
parent9f8d8f3b5fbd9a570401940a437a2cbda7fc29b1 (diff)
downloadfreebsd-ports-gnome-7477e7f4cda11699165d7dfcb42b11944b2f7ef7.tar.gz
freebsd-ports-gnome-7477e7f4cda11699165d7dfcb42b11944b2f7ef7.tar.zst
freebsd-ports-gnome-7477e7f4cda11699165d7dfcb42b11944b2f7ef7.zip
Emacs ports: Conform to 'Order of Variables in Port Makefiles' in PH
-rw-r--r--editors/emacs-devel/Makefile34
-rw-r--r--editors/emacs/Makefile33
2 files changed, 30 insertions, 37 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 0afd8fcd73b1..14f99d893af2 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -24,32 +24,26 @@ nox_PKGNAMESUFFIX= -devel_nox
USES= autoreconf:build cpe gmake localbase:ldflags makeinfo ncurses \
pkgconfig
+CPE_VENDOR= gnu
USE_GITHUB= yes
GH_ACCOUNT= emacs-mirror
GH_TAGNAME= d599dce
-CPE_VENDOR= gnu
-EMACS_VER= 27.0.50
-EMACS_REV= 20180220
GNU_CONFIGURE= yes
-INFO_PATH= ${DATADIR_REL}/info
-
-SUB_FILES= sources.el
-SUB_LIST= EMACS_VER=${EMACS_VER}
-
CONFIGURE_ARGS= --with-gameuser=games:games
-CONFIGURE_ENV= ac_cv_prog_liblockfile=no
-
-PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
-
CONFIGURE_ENV= ac_cv_header_sys_sysinfo_h=no \
ac_cv_prog_liblockfile=no
-INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse ede \
- ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc \
- ert eshell eudc eww flymake forms gnus htmlfontify idlwave ido info \
- mairix-el message mh-e newsticker nxml-mode octave-mode org pcl-cvs pgg \
- rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar \
- srecode todo-mode tramp url vhdl-mode vip viper widget wisent woman
+INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x \
+ ebrowse ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls \
+ emacs-mime epa erc ert eshell eudc eww flymake forms gnus \
+ htmlfontify idlwave ido info mairix-el message mh-e newsticker \
+ nxml-mode octave-mode org pcl-cvs pgg rcirc reftex remember \
+ sasl sc semantic ses sieve smtpmail speedbar srecode todo-mode \
+ tramp url vhdl-mode vip viper widget wisent woman
+INFO_PATH= ${DATADIR_REL}/info
+PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
+SUB_FILES= sources.el
+SUB_LIST= EMACS_VER=${EMACS_VER}
OPTIONS_DEFINE= ACL DBUS GCONF GNUTLS GSETTINGS LCMS2 LLDB M17N MAILUTILS \
MODULES OTF SCROLLBARS SOURCES THREADS XFT XIM XML XWIDGETS
@@ -165,7 +159,6 @@ XWIDGETS_CONFIGURE_WITH= xwidgets
XWIDGETS_LIB_DEPENDS= libwebkit2gtk-4.0.so:www/webkit2-gtk3
XWIDGETS_IMPLIES= GTK3
-
.if ${FLAVOR:U} == nox
CONFIGURE_ARGS+= --with-sound=no --without-cairo --without-dbus \
--without-gconf --without-gif --without-gsettings \
@@ -185,6 +178,9 @@ USE_XORG= ice sm x11 xcb xext xfixes xinerama xmu xrandr xt
USES+= desktop-file-utils
.endif
+EMACS_VER= 27.0.50
+EMACS_REV= 20180220
+
.include <bsd.port.options.mk>
# has graphics/ImageMagick been compiled with OPENMP?
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index a5edb172b4b0..82d53d6e9784 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -27,30 +27,25 @@ nox_CONFLICTS_INSTALL= emacs emacs-canna
nox_PKGNAMESUFFIX= -nox
USES= cpe gmake localbase:ldflags makeinfo ncurses pkgconfig tar:xz
-
CPE_VENDOR= gnu
-EMACS_VER= 25.3
-GNU_CONFIGURE= yes
-INFO_PATH= ${DATADIR_REL}/info
-
-SUB_FILES= sources.el
-SUB_LIST= ARCHLIBDIR=${PREFIX}/libexec/emacs/${EMACS_VER}/${CONFIGURE_TARGET} \
- EMACS_VER=${EMACS_VER} # sources.el
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-gameuser=games:games
-CONFIGURE_ENV= ac_cv_prog_liblockfile=no
-
-PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
-
CONFIGURE_ENV= ac_cv_header_sys_sysinfo_h=no \
ac_cv_prog_liblockfile=no
-INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x ebrowse ede \
- ediff edt efaq eieio eintr elisp emacs emacs-gnutls emacs-mime epa erc \
- ert eshell eudc eww flymake forms gnus htmlfontify idlwave ido info \
- mairix-el message mh-e newsticker nxml-mode octave-mode org pcl-cvs pgg \
- rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar \
- srecode todo-mode tramp url vhdl-mode vip viper widget wisent woman
+INFO= ada-mode auth autotype bovine calc ccmode cl dbus dired-x \
+ ebrowse ede ediff edt efaq eieio eintr elisp emacs emacs-gnutls \
+ emacs-mime epa erc ert eshell eudc eww flymake forms gnus \
+ htmlfontify idlwave ido info mairix-el message mh-e newsticker \
+ nxml-mode octave-mode org pcl-cvs pgg rcirc reftex remember \
+ sasl sc semantic ses sieve smtpmail speedbar srecode todo-mode \
+ tramp url vhdl-mode vip viper widget wisent woman
+INFO_PATH= ${DATADIR_REL}/info
+PLIST_SUB= EMACS_VER=${EMACS_VER} GNU_HOST=${CONFIGURE_TARGET}
+SUB_FILES= sources.el
+SUB_LIST= ARCHLIBDIR=${PREFIX}/libexec/emacs/${EMACS_VER}/${CONFIGURE_TARGET} \
+ EMACS_VER=${EMACS_VER} # sources.el
OPTIONS_DEFINE= ACL DBUS GCONF GNUTLS GSETTINGS LLDB M17N MAILUTILS MODULES OTF \
SCROLLBARS SOURCES XFT XIM XML XWIDGETS
@@ -190,6 +185,8 @@ USE_XORG= ice sm x11 xcb xext xfixes xinerama xmu xrandr xt
USES+= desktop-file-utils
.endif
+EMACS_VER= 25.3
+
.include <bsd.port.options.mk>
# has graphics/ImageMagick been compiled with OPENMP?