aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-20 03:46:44 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-20 03:46:44 +0800
commit748a3e92541554e47932f472afe28b595c6f35e3 (patch)
treeaa52af435aa3f805ee50ab053b6f9ffb22e9bfb0
parent0fa0bac92b02c73fa9329026fa8f665b0d0be0fb (diff)
downloadfreebsd-ports-gnome-748a3e92541554e47932f472afe28b595c6f35e3.tar.gz
freebsd-ports-gnome-748a3e92541554e47932f472afe28b595c6f35e3.tar.zst
freebsd-ports-gnome-748a3e92541554e47932f472afe28b595c6f35e3.zip
Add libusipp 2.24
usi++ (UNIX Socket Interface) is a low-level network-library for sending/receiving IP, IP6, ARP etc. packets directly on RAW or PACKET sockets. It can also be used for network-monitoring and rapid development of pentesting tools. It requires libpcap and libdnet if you want the Layer2 DNET provider. WWW: https://github.com/stealth/libusipp
-rw-r--r--net/Makefile1
-rw-r--r--net/libusipp/Makefile30
-rw-r--r--net/libusipp/distinfo3
-rw-r--r--net/libusipp/pkg-descr6
-rw-r--r--net/libusipp/pkg-plist33
5 files changed, 73 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1242941169e7..4296a625ed27 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -417,6 +417,7 @@
SUBDIR += libtnl
SUBDIR += libtrace
SUBDIR += libunp
+ SUBDIR += libusipp
SUBDIR += libutp
SUBDIR += libvncserver
SUBDIR += libwebsockets
diff --git a/net/libusipp/Makefile b/net/libusipp/Makefile
new file mode 100644
index 000000000000..065273cd0428
--- /dev/null
+++ b/net/libusipp/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libusipp
+PORTVERSION= 2.24
+DISTVERSIONPREFIX= libusipp-
+DISTVERSIONSUFFIX= s
+CATEGORIES= net
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Unix socket interface for C++ raw IP/IP6/UDP/TCP, layer 2 framework
+
+LICENSE= GPLv3+
+
+USES= autoreconf compiler:c++11-lang gmake
+
+GNU_CONFIGURE= yes
+WRKSRC_SUBDIR= src
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= stealth
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/usi++ ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/../usi++/*.h ${STAGEDIR}${PREFIX}/include/usi++
+ ${INSTALL_DATA} ${WRKSRC}/libusi++.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libusi++.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/net/libusipp/distinfo b/net/libusipp/distinfo
new file mode 100644
index 000000000000..3dd205e58aab
--- /dev/null
+++ b/net/libusipp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549818671
+SHA256 (stealth-libusipp-libusipp-2.24s_GH0.tar.gz) = da7703df75ba17cde726b1df85067627229b829893583c27fe082d77c505ed96
+SIZE (stealth-libusipp-libusipp-2.24s_GH0.tar.gz) = 69940
diff --git a/net/libusipp/pkg-descr b/net/libusipp/pkg-descr
new file mode 100644
index 000000000000..189188f2fb7a
--- /dev/null
+++ b/net/libusipp/pkg-descr
@@ -0,0 +1,6 @@
+usi++ (UNIX Socket Interface) is a low-level network-library for
+sending/receiving IP, IP6, ARP etc. packets directly on RAW or PACKET sockets.
+It can also be used for network-monitoring and rapid development of pentesting
+tools. It requires libpcap and libdnet if you want the Layer2 DNET provider.
+
+WWW: https://github.com/stealth/libusipp
diff --git a/net/libusipp/pkg-plist b/net/libusipp/pkg-plist
new file mode 100644
index 000000000000..4b3e6cae1e14
--- /dev/null
+++ b/net/libusipp/pkg-plist
@@ -0,0 +1,33 @@
+include/usi++/80211.h
+include/usi++/Layer2.h
+include/usi++/RX.h
+include/usi++/RX_fd.h
+include/usi++/RX_string.h
+include/usi++/TX.h
+include/usi++/TX_IP.h
+include/usi++/TX_IP6.h
+include/usi++/TX_dnet_eth.h
+include/usi++/TX_dnet_ip.h
+include/usi++/TX_pcap.h
+include/usi++/TX_pcap_eth.h
+include/usi++/TX_string.h
+include/usi++/arp.h
+include/usi++/config.h
+include/usi++/datalink.h
+include/usi++/eapol.h
+include/usi++/icmp.h
+include/usi++/icmp6.h
+include/usi++/ip.h
+include/usi++/ip6.h
+include/usi++/ipcomp.h
+include/usi++/misc.h
+include/usi++/object.h
+include/usi++/radiotap.h
+include/usi++/refcount.h
+include/usi++/tcp.h
+include/usi++/udp.h
+include/usi++/usi++.h
+include/usi++/usi-structs-compat.h
+include/usi++/usi-structs.h
+lib/libusi++.a
+lib/libusi++.so