aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-25 18:47:38 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-25 18:47:38 +0800
commit75fa31e910846f38fa3583a0ea554414fa26b04a (patch)
treed5693102d902ad8db044e3fb2b5f9b783adbbfe9
parent8d9b0d2a3c02f651c733f32aae988545cde311c3 (diff)
downloadfreebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.tar.gz
freebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.tar.zst
freebsd-ports-gnome-75fa31e910846f38fa3583a0ea554414fa26b04a.zip
Put back devel/p5-File-Spec - I was too quick making a decision to nuke it.
Mea culpa.
-rw-r--r--CVSROOT/modules1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Spec/Makefile32
-rw-r--r--devel/p5-File-Spec/distinfo1
-rw-r--r--devel/p5-File-Spec/pkg-comment1
-rw-r--r--devel/p5-File-Spec/pkg-descr9
-rw-r--r--devel/p5-File-Spec/pkg-plist12
-rw-r--r--devel/p5-PathTools/Makefile32
-rw-r--r--devel/p5-PathTools/distinfo1
-rw-r--r--devel/p5-PathTools/pkg-comment1
-rw-r--r--devel/p5-PathTools/pkg-descr9
-rw-r--r--devel/p5-PathTools/pkg-plist12
12 files changed, 112 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index 55642d3fe56e..8bde6248a20c 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -4678,6 +4678,7 @@ p5-File-Remove ports/devel/p5-File-Remove
p5-File-Rsync ports/net/p5-File-Rsync
p5-File-Slurp ports/devel/p5-File-Slurp
p5-File-Sort ports/misc/p5-File-Sort
+p5-File-Spec ports/devel/p5-File-Spec
p5-File-Sync ports/devel/p5-File-Sync
p5-File-Tail ports/devel/p5-File-Tail
p5-File-Temp ports/devel/p5-File-Temp
diff --git a/devel/Makefile b/devel/Makefile
index 692fa9f5121c..27a8ba3b888e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -400,6 +400,7 @@
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
SUBDIR += p5-File-Slurp
+ SUBDIR += p5-File-Spec
SUBDIR += p5-File-Sync
SUBDIR += p5-File-Tail
SUBDIR += p5-File-Temp
diff --git a/devel/p5-File-Spec/Makefile b/devel/p5-File-Spec/Makefile
new file mode 100644
index 000000000000..fd933a3c637b
--- /dev/null
+++ b/devel/p5-File-Spec/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-File-Spec
+# Date created: November 22, 2000
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec
+PORTVERSION= 0.82
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+PERL_CONFIGURE= yes
+MODULE_PREFIX= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+CONFIGURE_ARGS+=\
+ INSTALLPRIVLIB=${MODULE_PREFIX} \
+ INSTALLARCHLIB=${MODULE_PREFIX}/${PERL_ARCH}
+
+MAN3= File::Spec.3 \
+ File::Spec::Functions.3 \
+ File::Spec::Mac.3 \
+ File::Spec::OS2.3 \
+ File::Spec::Unix.3 \
+ File::Spec::VMS.3 \
+ File::Spec::Win32.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Spec/distinfo b/devel/p5-File-Spec/distinfo
new file mode 100644
index 000000000000..549bcdacad99
--- /dev/null
+++ b/devel/p5-File-Spec/distinfo
@@ -0,0 +1 @@
+MD5 (File-Spec-0.82.tar.gz) = df27080f675cdd6299c4f6b87ea859bd
diff --git a/devel/p5-File-Spec/pkg-comment b/devel/p5-File-Spec/pkg-comment
new file mode 100644
index 000000000000..a945e920b6e8
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-comment
@@ -0,0 +1 @@
+A Perl module for portably manipulating file specifications
diff --git a/devel/p5-File-Spec/pkg-descr b/devel/p5-File-Spec/pkg-descr
new file mode 100644
index 000000000000..c6b391dddffe
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-descr
@@ -0,0 +1,9 @@
+This module is designed to support operations commonly
+performed on file specifications (usually called "file
+names", but not to be confused with the contents of a
+file, or Perl's file handles), such as concatenating
+several directory and file names into a single path, or
+determining whether a path is rooted. It is based on code
+directly taken from MakeMaker 5.17, code written by
+Andreas Koenig, Andy Dougherty, Charles Bailey, Ilya
+Zakharevich, Paul Schinder, and others.
diff --git a/devel/p5-File-Spec/pkg-plist b/devel/p5-File-Spec/pkg-plist
new file mode 100644
index 000000000000..ca1e9c77b4fb
--- /dev/null
+++ b/devel/p5-File-Spec/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Functions.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/OS2.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/VMS.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/File/Spec
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true
diff --git a/devel/p5-PathTools/Makefile b/devel/p5-PathTools/Makefile
new file mode 100644
index 000000000000..fd933a3c637b
--- /dev/null
+++ b/devel/p5-PathTools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-File-Spec
+# Date created: November 22, 2000
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec
+PORTVERSION= 0.82
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+PERL_CONFIGURE= yes
+MODULE_PREFIX= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+CONFIGURE_ARGS+=\
+ INSTALLPRIVLIB=${MODULE_PREFIX} \
+ INSTALLARCHLIB=${MODULE_PREFIX}/${PERL_ARCH}
+
+MAN3= File::Spec.3 \
+ File::Spec::Functions.3 \
+ File::Spec::Mac.3 \
+ File::Spec::OS2.3 \
+ File::Spec::Unix.3 \
+ File::Spec::VMS.3 \
+ File::Spec::Win32.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-PathTools/distinfo b/devel/p5-PathTools/distinfo
new file mode 100644
index 000000000000..549bcdacad99
--- /dev/null
+++ b/devel/p5-PathTools/distinfo
@@ -0,0 +1 @@
+MD5 (File-Spec-0.82.tar.gz) = df27080f675cdd6299c4f6b87ea859bd
diff --git a/devel/p5-PathTools/pkg-comment b/devel/p5-PathTools/pkg-comment
new file mode 100644
index 000000000000..a945e920b6e8
--- /dev/null
+++ b/devel/p5-PathTools/pkg-comment
@@ -0,0 +1 @@
+A Perl module for portably manipulating file specifications
diff --git a/devel/p5-PathTools/pkg-descr b/devel/p5-PathTools/pkg-descr
new file mode 100644
index 000000000000..c6b391dddffe
--- /dev/null
+++ b/devel/p5-PathTools/pkg-descr
@@ -0,0 +1,9 @@
+This module is designed to support operations commonly
+performed on file specifications (usually called "file
+names", but not to be confused with the contents of a
+file, or Perl's file handles), such as concatenating
+several directory and file names into a single path, or
+determining whether a path is rooted. It is based on code
+directly taken from MakeMaker 5.17, code written by
+Andreas Koenig, Andy Dougherty, Charles Bailey, Ilya
+Zakharevich, Paul Schinder, and others.
diff --git a/devel/p5-PathTools/pkg-plist b/devel/p5-PathTools/pkg-plist
new file mode 100644
index 000000000000..ca1e9c77b4fb
--- /dev/null
+++ b/devel/p5-PathTools/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Functions.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Mac.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/OS2.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Unix.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/VMS.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/File/Spec.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Spec
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/File/Spec
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true