aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-11-26 20:29:22 +0800
committerrakuco <rakuco@FreeBSD.org>2015-11-26 20:29:22 +0800
commit75ff495b46528eddfe4e9603c54a857d8099f6bc (patch)
tree7cd807cec498af396919172b326286a7714fe75b
parent04a1ed3d5ebb2804c451ffaf91abfce8e0fed4ca (diff)
downloadfreebsd-ports-gnome-75ff495b46528eddfe4e9603c54a857d8099f6bc.tar.gz
freebsd-ports-gnome-75ff495b46528eddfe4e9603c54a857d8099f6bc.tar.zst
freebsd-ports-gnome-75ff495b46528eddfe4e9603c54a857d8099f6bc.zip
Add patch for the port to build with CMake 3.4.0.
-rw-r--r--x11/kgamma/files/patch-CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/x11/kgamma/files/patch-CMakeLists.txt b/x11/kgamma/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c8c15a5c03a0
--- /dev/null
+++ b/x11/kgamma/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+Make the port build with CMake 3.4.0.
+
+Stop relying on an implicit inclusion of the CheckIncludesFile module.
+Not upstreamable, the latest upstream version does not use that module
+anymore.
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -3,6 +3,7 @@ project(kgamma)
+ find_package(KDE4 REQUIRED)
+ include(KDE4Defaults)
+ include(MacroLibrary)
++include(CheckIncludeFiles)
+
+ find_package(X11 REQUIRED)
+