aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2009-08-18 04:13:26 +0800
committerdougb <dougb@FreeBSD.org>2009-08-18 04:13:26 +0800
commit7671c8add9dfe5c81d523d3ee4b9507e34900fb7 (patch)
treea442970196d015735c89aadabf8c21aea087cfe9
parent4ccc412152759d65e90c782df2e6dc3ea395a072 (diff)
downloadfreebsd-ports-gnome-7671c8add9dfe5c81d523d3ee4b9507e34900fb7.tar.gz
freebsd-ports-gnome-7671c8add9dfe5c81d523d3ee4b9507e34900fb7.tar.zst
freebsd-ports-gnome-7671c8add9dfe5c81d523d3ee4b9507e34900fb7.zip
Convert to have the option of using only libwraster instead of the
full Window Maker port. The default is still to use WM so no change to the package.
-rw-r--r--misc/wmweather+/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/misc/wmweather+/Makefile b/misc/wmweather+/Makefile
index a74aa6fca44b..11b8e074def6 100644
--- a/misc/wmweather+/Makefile
+++ b/misc/wmweather+/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= dougb@FreeBSD.org
COMMENT= Displays current conditions and forecasts with icons and text
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- wraster:${PORTSDIR}/x11-wm/windowmaker \
pcre:${PORTSDIR}/devel/pcre \
tiff:${PORTSDIR}/graphics/tiff \
Hermes:${PORTSDIR}/graphics/Hermes \
@@ -33,10 +32,20 @@ CONFIGURE_ARGS+= --with-libwraster=${LOCALBASE} \
--with-xpm-includes=${LOCALBASE} \
--with-xpm-libraries=${LOCALBASE}
+OPTIONS= WM "Depend on Window Maker port (otherwise only libwraster)" on
+
MAN1= wmweather+.1
PLIST_FILES= bin/wmweather+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_WM)
+LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/windowmaker
+.else
+LIB_DEPENDS+= wraster:${PORTSDIR}/x11-wm/libwraster
+.endif
+
post-patch:
@${CP} ${WRKSRC}/wmweather+.c ${WRKSRC}/wmweather+.c.dist
@${SED} -e "s#^void usage(int i) __THROW.*#void usage(int i);#" \
@@ -69,4 +78,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>