aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-03-09 01:49:44 +0800
committerpi <pi@FreeBSD.org>2016-03-09 01:49:44 +0800
commit76a5332a613e46b3df9d70c63c4b530a9d152713 (patch)
tree7851e9677c4672b6eb3b7589f8875ccfb0503158
parent0affb4019a50b63f753f7e08af9ec7556f7f1588 (diff)
downloadfreebsd-ports-gnome-76a5332a613e46b3df9d70c63c4b530a9d152713.tar.gz
freebsd-ports-gnome-76a5332a613e46b3df9d70c63c4b530a9d152713.tar.zst
freebsd-ports-gnome-76a5332a613e46b3df9d70c63c4b530a9d152713.zip
New port: ports-mgmt/portest
With portest, you can create, update, patch and revert a port tree with svn, git and portsnap. Portest can also do portlint testing, test a port with port test, or poudriere, and also generate a list of ports a patchfile(s) will modify. Portest is written in shell with minimal dependencies mostly using FreeBSD-base WWW: https://github.com/Ultima1252/portest PR: 207810 Submitted by: Ultima1252@gmail.com
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/portest/Makefile38
-rw-r--r--ports-mgmt/portest/distinfo2
-rw-r--r--ports-mgmt/portest/pkg-descr7
4 files changed, 48 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index a204605e74ba..2c62fefcabcb 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -44,6 +44,7 @@
SUBDIR += portconf
SUBDIR += portdowngrade
SUBDIR += portell
+ SUBDIR += portest
SUBDIR += portfind
SUBDIR += portless
SUBDIR += portlint
diff --git a/ports-mgmt/portest/Makefile b/ports-mgmt/portest/Makefile
new file mode 100644
index 000000000000..4d9162753fee
--- /dev/null
+++ b/ports-mgmt/portest/Makefile
@@ -0,0 +1,38 @@
+# Created by: Ultima <ultima1252@gmail.com>
+# $FreeBSD$
+
+PORTNAME= portest
+PORTVERSION= 0.1.4
+CATEGORIES= ports-mgmt
+
+MAINTAINER= ultima1252@gmail.com
+COMMENT= Patch file automation for FreeBSD-ports
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= portlint:${PORTSDIR}/ports-mgmt/portlint
+
+USE_GITHUB= yes
+GH_ACCOUNT= ultima1252
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/portest
+
+OPTIONS_DEFINE= GIT PORTTOOLS POUDRIERE
+OPTIONS_DEFAULT= GIT PORTTOOLS POUDRIERE
+
+GIT_DESC= Git support
+GIT_RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+PORTTOOLS_DESC= Porttools support
+PORTTOOLS_RUN_DEPENDS= port:${PORTSDIR}/ports-mgmt/porttools
+
+POUDRIERE_DESC= Poudriere and parallel build support
+POUDRIERE_RUN_DEPENDS= poudriere:${PORTSDIR}/ports-mgmt/poudriere \
+ tmux:${PORTSDIR}/sysutils/tmux
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/portest ${STAGEDIR}${PREFIX}/sbin/portest
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portest/distinfo b/ports-mgmt/portest/distinfo
new file mode 100644
index 000000000000..689582693765
--- /dev/null
+++ b/ports-mgmt/portest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ultima1252-portest-0.1.4_GH0.tar.gz) = e326011a6712197ef6a725efca198245440110870484efb2b3562f1d25215cbd
+SIZE (ultima1252-portest-0.1.4_GH0.tar.gz) = 7389
diff --git a/ports-mgmt/portest/pkg-descr b/ports-mgmt/portest/pkg-descr
new file mode 100644
index 000000000000..b34388d1ab4d
--- /dev/null
+++ b/ports-mgmt/portest/pkg-descr
@@ -0,0 +1,7 @@
+With portest, you can create, update, patch and revert a port tree with
+svn, git and portsnap. Portest can also do portlint testing, test a port
+with port test, or poudriere, and also generate a list of ports a
+patchfile(s) will modify. Portest is written in shell with minimal
+dependencies mostly using FreeBSD-base
+
+WWW: https://github.com/Ultima1252/portest