aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-10 14:05:46 +0800
committerbapt <bapt@FreeBSD.org>2014-09-10 14:05:46 +0800
commit7718d80a64adc108f4e2a8a01888d6a5d1187a0a (patch)
tree6e624479a6527d8c6b1fc03ae964133f6138b326
parentae341feedaece8de07807e53ed1edca374d90417 (diff)
downloadfreebsd-ports-gnome-7718d80a64adc108f4e2a8a01888d6a5d1187a0a.tar.gz
freebsd-ports-gnome-7718d80a64adc108f4e2a8a01888d6a5d1187a0a.tar.zst
freebsd-ports-gnome-7718d80a64adc108f4e2a8a01888d6a5d1187a0a.zip
Allow to specify full target directly from the slave
-rw-r--r--devel/binutils/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 83a90d3d866b..a5d53b8b0bc4 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -28,10 +28,11 @@ USES= bison gmake libtool tar:bzip2
GNU_CONFIGURE= yes
.if defined(PKGNAMEPREFIX)
+BUTARGET?= ${PKGNAMEPREFIX}${OPSYS:tl}
OPTIONS_EXCLUDE= NLS
INFO_PATH= ${PKGNAMEPREFIX:S/-$//}/info
CONFIGURE_ARGS+= --disable-shared \
- --target=${PKGNAMEPREFIX}${OPSYS:tl}
+ --target=${BUTARGET}
.else
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib