aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-02-05 13:28:36 +0800
committertota <tota@FreeBSD.org>2012-02-05 13:28:36 +0800
commit7745889fab236787b23b670f61932b0c8fdbe2e2 (patch)
treefb7115f9df09ff9896ce4fbbc0aefed5b984a1bd
parent2c52409a7aa704dc3f08e6720164870dfea3658f (diff)
downloadfreebsd-ports-gnome-7745889fab236787b23b670f61932b0c8fdbe2e2.tar.gz
freebsd-ports-gnome-7745889fab236787b23b670f61932b0c8fdbe2e2.tar.zst
freebsd-ports-gnome-7745889fab236787b23b670f61932b0c8fdbe2e2.zip
- Update to 1.0.5
- Add a patch to fix CodeRay API
-rw-r--r--misc/rabbit/Makefile11
-rw-r--r--misc/rabbit/distinfo4
-rw-r--r--misc/rabbit/files/patch-base.rb11
-rw-r--r--misc/rabbit/files/patch-coderay.rb64
-rw-r--r--misc/rabbit/files/patch-rabbirack10
-rw-r--r--misc/rabbit/files/patch-rabbit-command11
-rw-r--r--misc/rabbit/pkg-plist3
7 files changed, 76 insertions, 38 deletions
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index 5f6e7e116c63..f3f02fc14996 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= rabbit
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= misc ruby
MASTER_SITES= http://rabbit-shockers.org/download/ \
- ${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/rabbit|}
+ LOCAL
+MASTER_SITE_SUBDIR= tota/${PORTNAME}
MAINTAINER= tota@FreeBSD.org
COMMENT= An RD-document-based presentation application
@@ -23,10 +24,10 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
hikidoc:${PORTSDIR}/textproc/ruby-hikidoc \
rubygem-nokogiri>0:${PORTSDIR}/textproc/rubygem-nokogiri \
rubygem-sinatra>0:${PORTSDIR}/www/rubygem-sinatra \
- rubygem-rack>0:${PORTSDIR}/www/rubygem-rack \
rubygem-haml>0:${PORTSDIR}/www/rubygem-haml \
rd2:${PORTSDIR}/textproc/ruby-rdtool \
- rubygem-coderay>0:${PORTSDIR}/textproc/rubygem-coderay
+ rubygem-coderay>=1.0.0:${PORTSDIR}/textproc/rubygem-coderay \
+ rubygem-kramdown>0:${PORTSDIR}/textproc/rubygem-kramdown
USE_RUBY= yes
USE_RUBY_SETUP= yes
@@ -66,9 +67,11 @@ RUN_DEPENDS+= rubygem-twitter_oauth>=0:${PORTSDIR}/security/rubygem-twitter_oaut
post-patch:
${RM} ${WRKSRC}/bin/rabwii
+ ${RMDIR} ${WRKSRC}/lib/rt
${RUBY} -i -pe 'sub %r|((\s*)require "rack")|, %Q|\\2require "rubygems"\n\\1|' ${WRKSRC}/bin/rabbirack
${RUBY} -i -pe 'sub %r|(require "hikidoc")|, %Q|require "rubygems"\n\\1|' ${WRKSRC}/lib/rabbit/parser/wiki.rb
${RUBY} -i -pe "sub %r|((\s*)require 'twitter_oauth')|, %Q|\\\2require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/twitter.rb
+ ${RUBY} -i -pe "sub %r|(require 'coderay')|, %Q|require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/parser/ext/coderay.rb
.if defined(WITH_MIMETEX)
${REINPLACE_CMD} -e 's|"mimetex.cgi"|"${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi"|' \
${WRKSRC}/lib/rabbit/parser/ext/tex.rb
diff --git a/misc/rabbit/distinfo b/misc/rabbit/distinfo
index a5af2d8d89ca..f644545afd26 100644
--- a/misc/rabbit/distinfo
+++ b/misc/rabbit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rabbit-1.0.4.tar.gz) = 4f04ffe71a02a6323a66c3b0dd55f07d17c7558dbd346f1b4c6cc72510cb69b9
-SIZE (rabbit-1.0.4.tar.gz) = 5891669
+SHA256 (rabbit-1.0.5.tar.gz) = 8d10e8affbdf4507e1481f8409dceca3ee43b5ff1beb9476788594782576e44a
+SIZE (rabbit-1.0.5.tar.gz) = 5886310
diff --git a/misc/rabbit/files/patch-base.rb b/misc/rabbit/files/patch-base.rb
deleted file mode 100644
index 5d0e77207af0..000000000000
--- a/misc/rabbit/files/patch-base.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/rabbit/logger/base.rb.orig 2011-04-29 16:19:39.000000000 +0900
-+++ lib/rabbit/logger/base.rb 2011-08-20 18:53:13.000000000 +0900
-@@ -65,7 +65,7 @@
- log(INFO, message_or_error, &block)
- end
-
-- def warn(message_or_error=nil, &block)
-+ def warning(message_or_error=nil, &block)
- log(WARNING, message_or_error, &block)
- end
-
diff --git a/misc/rabbit/files/patch-coderay.rb b/misc/rabbit/files/patch-coderay.rb
new file mode 100644
index 000000000000..ce52bee2985f
--- /dev/null
+++ b/misc/rabbit/files/patch-coderay.rb
@@ -0,0 +1,64 @@
+--- lib/rabbit/parser/ext/coderay.rb.orig 2011-07-16 05:59:37.000000000 +0900
++++ lib/rabbit/parser/ext/coderay.rb 2012-02-05 11:24:16.000000000 +0900
+@@ -21,7 +21,7 @@
+ def setup(options)
+ super
+ @out = SyntaxHighlightingBlock.new
+- @elements = [@out]
++ @containers = [@out]
+ end
+
+ def text_token(text, type=:plain)
+@@ -29,36 +29,39 @@
+ escaped_text = Escape.escape_meta_character(text)
+ text_element = SyntaxHighlightingText.new(Text.new(escaped_text))
+ tag_name = type.to_s.gsub(/_/, '-')
+- CustomTag.new("syntax-#{tag_name}", text_element)
++ tag = CustomTag.new("syntax-#{tag_name}", text_element)
++ current_container << tag
+ end
+
+- def open_token(kind)
+- p [:open, kind] if Utils.syntax_highlighting_debug?
+- @out = TextContainer.new
+- @elements << @out
+- CustomTag.new("syntax-#{kind}")
++ def begin_group(kind)
++ p [:begin_group, kind] if Utils.syntax_highlighting_debug?
++ @containers << TextContainer.new
++ tag = CustomTag.new("syntax-#{kind}")
++ current_container << tag
+ end
+
+ def begin_line(kind)
+ p [:begin_line, kind] if Utils.syntax_highlighting_debug?
+- nil
+ end
+
+ def end_line(kind)
+ p [:end_line, kind] if Utils.syntax_highlighting_debug?
+- nil
+ end
+
+- def close_token(kind)
+- p [:close, kind] if Utils.syntax_highlighting_debug?
+- block = @elements.pop
+- @out = @elements.last
+- block
++ def end_group(kind)
++ p [:end_group, kind] if Utils.syntax_highlighting_debug?
++ block = @containers.pop
++ current_container << block
+ end
+
+ def finish(options)
+ super
+ end
++
++ private
++ def current_container
++ @containers.last
++ end
+ end
+ end
+ end
diff --git a/misc/rabbit/files/patch-rabbirack b/misc/rabbit/files/patch-rabbirack
deleted file mode 100644
index 72faaf1c4234..000000000000
--- a/misc/rabbit/files/patch-rabbirack
+++ /dev/null
@@ -1,10 +0,0 @@
---- bin/rabbirack.orig 2011-08-20 22:42:21.000000000 +0900
-+++ bin/rabbirack 2011-08-21 03:44:41.000000000 +0900
-@@ -90,6 +90,6 @@
- else
- require "rack"
- ARGV.shift if rack_runner == "rackup"
-- ARGV.unshift("--option", "config=#{config_ru_path}")
-+ ARGV.unshift(":config", "#{config_ru_path}")
- Rack::Server.start
- end
diff --git a/misc/rabbit/files/patch-rabbit-command b/misc/rabbit/files/patch-rabbit-command
deleted file mode 100644
index bc1d1b3090fa..000000000000
--- a/misc/rabbit/files/patch-rabbit-command
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/rabbit-command.orig 2011-07-13 20:05:07.000000000 +0900
-+++ bin/rabbit-command 2011-08-20 19:22:06.000000000 +0900
-@@ -98,7 +98,7 @@
- if options.druby_uri_specified
- logger.warning(_("--druby-uri is deprecated. Use --rabbit-uri instead."))
- end
-- rabbit = DRbObject.new_with_uri(options.druby_uri)
-+ rabbit = DRbObject.new_with_uri(options.rabbit_uri)
- options.commands.each do |output, method, *args|
- result = rabbit.send(method, *args)
- send(output, result) if output
diff --git a/misc/rabbit/pkg-plist b/misc/rabbit/pkg-plist
index 5f8be88d8645..2eea694e1c47 100644
--- a/misc/rabbit/pkg-plist
+++ b/misc/rabbit/pkg-plist
@@ -102,6 +102,8 @@ bin/rabrick
%%RUBY_SITELIBDIR%%/rabbit/parser/ext/inline.rb
%%RUBY_SITELIBDIR%%/rabbit/parser/ext/tex.rb
%%RUBY_SITELIBDIR%%/rabbit/parser/image.rb
+%%RUBY_SITELIBDIR%%/rabbit/parser/markdown.rb
+%%RUBY_SITELIBDIR%%/rabbit/parser/markdown/converter.rb
%%RUBY_SITELIBDIR%%/rabbit/parser/pause-support.rb
%%RUBY_SITELIBDIR%%/rabbit/parser/pdf.rb
%%RUBY_SITELIBDIR%%/rabbit/parser/rd.rb
@@ -530,6 +532,7 @@ bin/rabrick
@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser/rd/rt
@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser/rd/ext
@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser/rd
+@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser/markdown
@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser/ext
@dirrm %%RUBY_SITELIBDIR%%/rabbit/parser
@dirrm %%RUBY_SITELIBDIR%%/rabbit/middleware/views
4f4bf8894937b23efd8873815e2b3948a13f63c'>- Convert to OPTIONSpav2004-08-211-9/+6 * Update to 2.6.0.4.marcus2004-08-208-297/+129 * Portlint (bad cut / paste).thierry2004-08-181-2/+2 * Add rxvt-unicode, a clone of the well known terminal emulator rxvt,thierry2004-08-1814-154/+313 * Update nVidia binary drivers to most recent released version, 6113.osa2004-08-178-112/+85 * This now seems to build on 5.xkris2004-08-171-4/+0 * Fix plist.bland2004-08-174-2/+4 * Add missed install/uninstall handlers for gconf schemas.bland2004-08-174-0/+6 * USE_INTLTOOL_VER -> USE_INC_LIBTOOL_VER to let lthack actuallybland2004-08-171-1/+1 * Chase the gstreamer shared lib bump.marcus2004-08-172-2/+2 * Update to 0.10.1, this fixed some serious bugs of 0.10.0.mezz2004-08-173-4/+3 * Update to version 196krion2004-08-162-4/+3 * - Add ruby-gtksourceview and ruby-panelapplet.mezz2004-08-161-0/+3 * - Update to 0.10.0.mezz2004-08-155-18/+15 * Add nvidia-settings 1.0, Display Control Panel for XFree86/X.org NVidiabland2004-08-155-0/+47 * update to 1.1oliver2004-08-152-8/+7 * BROKEN: Unfetchablekris2004-08-151-0/+2 * Reset maintainer: auto-responds with a request to check a website thatkris2004-08-151-1/+1 * Restore break.krion2004-08-141-5/+4 * Handle 'default' in switch more neatly.krion2004-08-141-4/+6 * Fix build with gcc-3.4krion2004-08-141-0/+13 * Add sisctrl 0.0.20040622, Display Control Panel for XFree86/X.org SiSbland2004-08-144-0/+37 * Support CFLAGS properlykrion2004-08-134-17/+19 * Add another missed patch.lofi2004-08-134-2/+78 * A couple of patches didn't make it from the kde-freebsd repo into ports.lofi2004-08-1346-9/+2122 * Forgot to commit this bit, without it the koffice-i18n ports break.lofi2004-08-132-4/+4 * Tell genkdmconf to ignore existing bits of xdm/kdm configuration, if itlofi2004-08-127-14/+7 * Update to 2.6.1.2.marcus2004-08-113-31/+6 * Factor out all but one of the build switches of the KDE main module portslofi2004-08-1177-15094/+17384 * Add uxterm support.krion2004-08-101-0/+2 * - Detect and use xorgpav2004-08-101-2/+2 * - Cache distfile locally.bland2004-08-104-8/+6 * Update XFree86 clients to 4.4 release. Release notes are available atmarcus2004-08-1041-1139/+741 * s/BUILD_DEPENDS/RUN_DEPENDS/ for the xterm-static dependency to make sure thatanholt2004-08-101-1/+1 * Update to version 195krion2004-08-102-3/+3 * Pet portlint.krion2004-08-043-4/+4 * Add more MASTER_SITES for redundancy.krion2004-08-041-1/+2 * Bump PORTREVISION to chase the gstreamer shared lib version.marcus2004-08-032-2/+2 * - Fix build with gcc-3.4pav2004-07-312-0/+40 * Fix typo in plistkrion2004-07-302-7/+7 * - Fix distinfopav2004-07-301-2/+2 * Remove extra directory.adamw2004-07-292-2/+0 * Install the gdm/Sessions directory manually.adamw2004-07-291-0/+1 * Add bbappconf, an utility that makes it possible to set some optionspav2004-07-296-0/+53 * Move a bunch of now unique stuff out of gnomehier and intoadamw2004-07-2814-3/+35 * Update to version 194krion2004-07-283-12/+39 * Add MASTER_SITES for more redundancy.krion2004-07-271-1/+2 * Fix package buildkrion2004-07-271-1/+1 * Add one more hack allowing users to update with xtermkrion2004-07-272-2/+17 * Add superugly hack allowing users to update xorg-clients tokrion2004-07-272-7/+15 * Add gnomesu to the list of "geek toys."marcus2004-07-271-2/+3 * Remove CONFLICTS with x11/xorg-clientskrion2004-07-271-5/+3 * Move x11/xterm to BUILD_DEPENDS.krion2004-07-274-15/+26 * Register missing CONFLICTS, mostly on xorg-libraries-*anholt2004-07-2727-27/+27 * Fix build after X.Org patch.anholt2004-07-261-7/+0 * Only depend on the DRI on architectures it's supported on.anholt2004-07-261-3/+7 * Update to version 2.1.2krion2004-07-263-15/+34 * Add xorg-documents depenency. I think we've got a full xorg distribution now.anholt2004-07-241-1/+2 * New port: xorg-documents, a package of the X11 library and protocolanholt2004-07-247-0/+156 * Add xterm-193,krion2004-07-245-0/+51 * - Extend IGNORE message, point users to instructions how to switchpav2004-07-243-3/+3 * Bump PORTREVISION as these need to be recompiled with X.Org.marcus2004-07-241-0/+1 * Add IGNORE if X_WINDOW_SYSTEM is set wrong for this port.anholt2004-07-241-0/+6 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-2428-50/+77 * Add xorg-nestserver to the list.anholt2004-07-241-0/+2 * Update to 2.6.2.1.marcus2004-07-226-20/+36 * Update port: x11/xlockmore to 5.13edwin2004-07-212-3/+3 * Change maintainer's mail.krion2004-07-211-3/+3 * Add some more geektools to the mix.marcus2004-07-211-1/+5 * Handle the special GConf entries file correctly.marcus2004-07-202-0/+8 * Update to 2.6.3bland2004-07-193-3/+6 * Update workrave to use the new gtkmm26 stuff.vs2004-07-191-2/+2 * update to xfce4-4.0.6oliver2004-07-194-6/+6 * Axe obsolete patch bit.bland2004-07-151-9/+0 * Install documentationvs2004-07-141-0/+10 * Hosted on SourceForgevs2004-07-132-2/+4 * Add fbpanel, a lightweight, netwm compliant desktop panel. It includespav2004-07-138-0/+99 * Add a new tweakable knob, WITH_XSCREENSAVER, and announce it.bms2004-07-121-2/+18 * Include the manual page in installation.bms2004-07-121-0/+7 * Pet portlint.lofi2004-07-121-0/+1 * Add dependency on the DRI, now that the server doesn't do that itself.anholt2004-07-121-1/+2 * BROKEN: Configure failskris2004-07-111-0/+2 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-1019-19/+19 * Add LATEST_LINK.bland2004-07-081-0/+2 * Add libgnomemm 2.6.0 after repocopy from libgnomemm,bland2004-07-086-42/+36 * Fix PREFIX setting to match other xlibs ports and unmark BROKEN on -current.anholt2004-07-081-3/+7 * Install xrender.pc, required by xcursor.pcanholt2004-07-083-0/+41 * Use the new GConf handling policy, this will be required for GNOME 2.7/2.8 ormezz2004-07-087-411/+78 * - Update to 1.6.1pav2004-07-065-46/+26 * Add fix for VuXML ID: ff00f2ce-c54c-11d8-b708-00061bc2ad93anholt2004-07-062-0/+18 * Chase the gnomenetwork->gnomenettool name change.marcus2004-07-061-1/+1 * Add brightside, a tool that adds edge and corner actions to the GNOME desktop.marcus2004-07-028-0/+466 * Autotools cleanup. Remove autoconf257 (259), automake17 (18), andade2004-07-021-1/+1 * Add intlhack to fix build on -STABLE.bland2004-07-012-2/+2 * Add missing buildtime dependency.perky2004-06-301-0/+1 * Add ruby-gtktrayicon 0.1.0,perky2004-06-305-0/+38 * Update to 1.03.marcus2004-06-293-3/+16 * Update to GNOME 2.6.2. The full set of changesis listed atmarcus2004-06-294-5/+4 * Use the new new GConf handling scheme.marcus2004-06-292-144/+60 * Update to 2.6.2.adamw2004-06-296-8/+8 * Set default FirstVT value to 9 which in most of the cases will protectbland2004-06-251-8/+15 * Update to 0.06.mezz2004-06-253-4/+21 * Update to 0.7.marcus2004-06-252-4/+4 * Remove stale mastersite.linimon2004-06-252-3/+2 * Work around a bug in QString::fromUtf8arved2004-06-242-0/+46 * - Add two knobs:mich2004-06-231-3/+16 * unbreak 4.x.sf2004-06-231-1/+1 * Add user-selector-applet 0.0.7, fast user switching applet for GNOME.bland2004-06-2313-0/+125