aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-03-17 03:44:01 +0800
committerpav <pav@FreeBSD.org>2006-03-17 03:44:01 +0800
commit77cdc6db0d1173ca482449d512ababd58f811da5 (patch)
treec4a8f500d52253c46f43e5ff815b22c5a25bb9ba
parent467764f4a1ab0d1c022176d01dfbae7ae7d73b07 (diff)
downloadfreebsd-ports-gnome-77cdc6db0d1173ca482449d512ababd58f811da5.tar.gz
freebsd-ports-gnome-77cdc6db0d1173ca482449d512ababd58f811da5.tar.zst
freebsd-ports-gnome-77cdc6db0d1173ca482449d512ababd58f811da5.zip
- Update to 2.2.6
- Change flag to enable/disable SMP instead of obsolete method of specifying the number of CPU's PR: ports/94533 Submitted by: Sean Farley <sean-freebsd@farley.org>
-rw-r--r--emulators/bochs/Makefile16
-rw-r--r--emulators/bochs/distinfo6
-rw-r--r--emulators/bochs/files/patch-aa38
-rw-r--r--emulators/bochs/files/patch-iodev-eth_vde.cc21
-rw-r--r--emulators/bochs/pkg-plist5
5 files changed, 52 insertions, 34 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 021903f16c91..d74df2dd36bd 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.6
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -20,7 +20,6 @@ BUILD_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
USE_XLIB= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -39,17 +38,14 @@ MANCOMPRESSED= yes
MAN1= bochs.1 bochs-dlx.1 bxcommit.1 bximage.1
MAN5= bochsrc.5
-.if defined(WITH_BOCHS_PROCESSORS)
-.if ${WITH_BOCHS_PROCESSORS} < 1 || ${WITH_BOCHS_PROCESSORS} > 15
-IGNORE= Cannot install: WITH_BOCHS_PROCESSORS must be an integer value between 1 and 15
-.endif
-CONFIGURE_ARGS+= --enable-processors=${WITH_BOCHS_PROCESSORS}
+.if defined(WITH_BOCHS_SMP)
+CONFIGURE_ARGS+= --enable-smp
WITH_BOCHS_CPU_LEVEL= 6
.endif
.if defined(WITH_BOCHS_CPU_LEVEL)
.if ${WITH_BOCHS_CPU_LEVEL} < 3 || ${WITH_BOCHS_CPU_LEVEL} > 6
-IGNORE= Cannot install: WITH_BOCHS_CPU_LEVEL must be an integer value between 3 and 6
+IGNORE= cannot install: WITH_BOCHS_CPU_LEVEL must be an integer value between 3 and 6
.endif
CONFIGURE_ARGS+= --enable-cpu-level=${WITH_BOCHS_CPU_LEVEL}
.if ${WITH_BOCHS_CPU_LEVEL} < 5
@@ -98,9 +94,9 @@ pre-patch::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_GUI_NOGUI=yes\""
@${ECHO_MSG}
.endif
-.if !defined(WITH_BOCHS_PROCESSORS)
+.if !defined(WITH_BOCHS_SMP)
@${ECHO_MSG} "If you want to compile with SMP support (implies WITH_BOCHS_CPU_LEVEL=6),"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_PROCESSORS=<number of processors>\""
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_SMP\""
@${ECHO_MSG}
.endif
.if !defined(WITH_BOCHS_DEBUGGER)
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index dfc9252f6861..06c7197a89a8 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,3 +1,3 @@
-MD5 (bochs-2.2.1.tar.gz) = 50484c75d8175fcd97a81432ac18fb71
-SHA256 (bochs-2.2.1.tar.gz) = e04f054164ea489c9f52794c7e0b214d72238212362db8382fdffe7df1fbd52c
-SIZE (bochs-2.2.1.tar.gz) = 3785329
+MD5 (bochs-2.2.6.tar.gz) = 961482eb78b55fe3e0e0639e34b4c2c1
+SHA256 (bochs-2.2.6.tar.gz) = 25447ca196794bb2e00d314038f75ad8aeead87dcf34e9501598b900dea639ee
+SIZE (bochs-2.2.6.tar.gz) = 3765867
diff --git a/emulators/bochs/files/patch-aa b/emulators/bochs/files/patch-aa
index a30a51758d2b..12d5dae4a650 100644
--- a/emulators/bochs/files/patch-aa
+++ b/emulators/bochs/files/patch-aa
@@ -1,24 +1,28 @@
---- .bochsrc.orig Fri May 13 20:10:58 2005
-+++ .bochsrc Sat Jun 18 06:06:15 2005
-@@ -70,7 +70,7 @@
- # You can also use the environment variable $BXSHARE to specify the
- # location of the BIOS.
+--- .bochsrc.orig Sun Jan 29 07:56:01 2006
++++ .bochsrc Mon Feb 20 21:10:38 2006
+@@ -74,7 +74,7 @@
+ # now supported, but we still recommend to use the BIOS distributed with
+ # Bochs. Now the start address can be calculated from image size.
#=======================================================================
-romimage: file=$BXSHARE/BIOS-bochs-latest, address=0xf0000
-+romimage: file=bios/BIOS-bochs-latest, address=0xf0000
- #romimage: file=bios/BIOS-bochs-2-processors, address=0xf0000
- #romimage: file=bios/BIOS-bochs-4-processors, address=0xf0000
- #romimage: file=bios/rombios.bin, address=0xf0000
-@@ -109,7 +109,7 @@
++romimage: file=/usr/local/share/bochs/BIOS-bochs-latest, address=0xf0000
+ #romimage: file=mybios.bin, address=0xfff80000 # 512k at memory top
+ #romimage: file=mybios.bin # calculate start address from image size
+
+@@ -147,9 +147,9 @@
+ # VGAROMIMAGE
# You now need to load a VGA ROM BIOS into C0000.
#=======================================================================
- #vgaromimage: file=bios/VGABIOS-elpin-2.40
+-#vgaromimage: file=bios/VGABIOS-elpin-2.40
-vgaromimage: file=$BXSHARE/VGABIOS-lgpl-latest
-+vgaromimage: file=bios/VGABIOS-lgpl-latest
- #vgaromimage: file=bios/VGABIOS-lgpl-latest-cirrus
+-#vgaromimage: file=bios/VGABIOS-lgpl-latest-cirrus
++#vgaromimage: file=/usr/local/share/bochs/VGABIOS-elpin-2.40
++vgaromimage: file=/usr/local/share/bochs/VGABIOS-lgpl-latest
++#vgaromimage: file=/usr/local/share/bochs/VGABIOS-lgpl-latest-cirrus
#=======================================================================
-@@ -301,7 +301,7 @@
+ # VGA:
+@@ -319,7 +319,7 @@
#
# Default value are sync=none, time0=local
#=======================================================================
@@ -27,7 +31,7 @@
#=======================================================================
-@@ -326,8 +326,8 @@
+@@ -344,8 +344,8 @@
# log: ./bochs.out
# log: /dev/tty
#=======================================================================
@@ -38,7 +42,7 @@
#=======================================================================
# LOGPREFIX:
-@@ -367,7 +367,7 @@
+@@ -385,7 +385,7 @@
# cause bochs to become unstable. The panic is a "graceful exit," so
# if you disable it you may get a spectacular disaster instead.
#=======================================================================
@@ -47,7 +51,7 @@
error: action=report
info: action=report
debug: action=ignore
-@@ -422,7 +422,7 @@
+@@ -442,7 +442,7 @@
# parport2: enabled=1, file="/dev/lp0"
# parport1: enabled=0
#=======================================================================
diff --git a/emulators/bochs/files/patch-iodev-eth_vde.cc b/emulators/bochs/files/patch-iodev-eth_vde.cc
new file mode 100644
index 000000000000..9556d729027f
--- /dev/null
+++ b/emulators/bochs/files/patch-iodev-eth_vde.cc
@@ -0,0 +1,21 @@
+--- iodev/eth_vde.cc.orig Sat Dec 10 12:37:35 2005
++++ iodev/eth_vde.cc Thu Mar 16 13:02:15 2006
+@@ -41,13 +41,17 @@
+ #include <sys/poll.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+-#include <asm/types.h>
+ #include <sys/socket.h>
+ #include <sys/uio.h>
+ #include <sys/wait.h>
+ #include <sys/un.h>
++#if defined(__linux__)
++#include <asm/types.h>
+ #include <linux/netlink.h>
+ #include <linux/if.h>
++#elif BX_HAVE_NET_IF_H
++#include <net/if.h>
++#endif
+ #include <assert.h>
+ #include <fcntl.h>
+ #include <errno.h>
diff --git a/emulators/bochs/pkg-plist b/emulators/bochs/pkg-plist
index 841a3385f2bc..a6309e226e33 100644
--- a/emulators/bochs/pkg-plist
+++ b/emulators/bochs/pkg-plist
@@ -2,9 +2,6 @@
bin/bochs
bin/bxcommit
bin/bximage
-%%DATADIR%%/BIOS-bochs-2-processors
-%%DATADIR%%/BIOS-bochs-4-processors
-%%DATADIR%%/BIOS-bochs-8-processors
%%DATADIR%%/BIOS-bochs-latest
%%DATADIR%%/VGABIOS-elpin-2.40
%%DATADIR%%/VGABIOS-elpin-LICENSE
@@ -23,6 +20,7 @@ bin/bximage
%%DATADIR%%/keymaps/x11-pc-it.map
%%DATADIR%%/keymaps/x11-pc-ru.map
%%DATADIR%%/keymaps/x11-pc-se.map
+%%DATADIR%%/keymaps/x11-pc-si.map
%%DATADIR%%/keymaps/x11-pc-uk.map
%%DATADIR%%/keymaps/x11-pc-us.map
%%DOCSDIR%%/CHANGES
@@ -33,7 +31,6 @@ bin/bximage
%%PORTDOCS%%%%DOCSDIR%%/biossums.txt
%%PORTDOCS%%%%DOCSDIR%%/cvs-structure.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Linux.html
-%%PORTDOCS%%%%DOCSDIR%%/html/codingguidelines.html
%%PORTDOCS%%%%DOCSDIR%%/html/cosimulation.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/iodebug.html