aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2013-12-04 03:29:05 +0800
committersbruno <sbruno@FreeBSD.org>2013-12-04 03:29:05 +0800
commit77e7f97ea0f0c1f5cfa3f229f167a16fb0c05395 (patch)
treee2d1c8feb4942ca8dd9d190f6f981b725d7c35f6
parent9c60aa1f41e6301c2fe56fb09581bdf1a893bfae (diff)
downloadfreebsd-ports-gnome-77e7f97ea0f0c1f5cfa3f229f167a16fb0c05395.tar.gz
freebsd-ports-gnome-77e7f97ea0f0c1f5cfa3f229f167a16fb0c05395.tar.zst
freebsd-ports-gnome-77e7f97ea0f0c1f5cfa3f229f167a16fb0c05395.zip
Pointyhat to me.
SPOTIFY support references the built in clementine library support module for the service that requires qca2 support. SPOTIFY_BLOB references some magical external library (from the vendor), that can be used in its place. There isn't a clearly obvious way to disable SPOTIFY support alltogether and the original, pre svn r335260 version of the SPOTIFY logic is correct Reported by: Jimmy Olgeni <olgeni@olgeni.com>
-rw-r--r--audio/clementine-player/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index b8285a809014..1ccc6a4f5c94 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clementine
PORTVERSION= 1.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -player
@@ -60,7 +60,7 @@ WIIMOTEDEV_DESC= Wiimote support
MOODBAR_DESC= Moodbar Support
USE_BUILTIN_TAGLIB= Use Clementine builtin taglib support
-OPTIONS_DEFAULT= AUDIOCD DEVICEKIT GIO LASTFM MTP VISUALISATION \
+OPTIONS_DEFAULT= AUDIOCD DEVICEKIT GIO LASTFM MTP SPOTIFY VISUALISATION \
WIIMOTEDEV MOODBAR
.include <bsd.port.options.mk>
@@ -132,10 +132,10 @@ CMAKE_ARGS+= -DENABLE_LIBMTP=OFF
.endif
.if ${PORT_OPTIONS:MSPOTIFY}
-CMAKE_ARGS+= -DENABLE_SPOTIFY_BLOB=ON
+CMAKE_ARGS+= -DENABLE_SPOTIFY=ON
LIB_DEPENDS+= qca:${PORTSDIR}/devel/qca
.else
-CMAKE_ARGS+= -DENABLE_SPOTIFY_BLOB=OFF
+CMAKE_ARGS+= -DENABLE_SPOTIFY=OFF -DENABLE_SPOTIFY_BLOB=OFF
.endif
.if ${PORT_OPTIONS:MVISUALISATION}