aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-07 04:11:44 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-07 04:11:44 +0800
commit77ec57eb2c25353ff24151ff1c4b02173ea324fd (patch)
tree3b6823952fc5f72afd3f0dde2e210df097e689d2
parenta5dff160b44e0ff20e40e83a9dc532c32434a72b (diff)
downloadfreebsd-ports-gnome-77ec57eb2c25353ff24151ff1c4b02173ea324fd.tar.gz
freebsd-ports-gnome-77ec57eb2c25353ff24151ff1c4b02173ea324fd.tar.zst
freebsd-ports-gnome-77ec57eb2c25353ff24151ff1c4b02173ea324fd.zip
New port: archivers/ark
This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D14822
-rw-r--r--MOVED1
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/ark/Makefile37
-rw-r--r--archivers/ark/distinfo3
-rw-r--r--archivers/ark/pkg-descr11
-rw-r--r--archivers/ark/pkg-plist96
6 files changed, 148 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 907313d1098a..1a05ee1a5c45 100644
--- a/MOVED
+++ b/MOVED
@@ -10110,7 +10110,6 @@ graphics/libksane|graphics/libksane-kde4|2018-02-22|Make room for KDE updates
graphics/ksaneplugin|graphics/ksaneplugin-kde4|2018-02-22|Make room for KDE updates
graphics/kcolorchooser|graphics/kcolorchooser-kde4|2018-02-22|Make room for KDE updates
graphics/kqtquickcharts|graphics/kqtquickcharts-kde4|2018-02-22|Make room for KDE updates
-archivers/ark|archivers/ark-kde4|2018-02-22|Make room for KDE updates
x11/kde4-baseapps|x11/kde-baseapps-kde4|2018-02-22|Make room for KDE updates
x11/kde4-runtime|x11/kde-runtime-kde4|2018-02-22|Make room for KDE updates
x11/kde4-workspace|x11/kde-workspace-kde4|2018-02-22|Make room for KDE updates
diff --git a/archivers/Makefile b/archivers/Makefile
index bb7ec1a4e95c..407cdc86e601 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -8,6 +8,7 @@
SUBDIR += amigadepacker
SUBDIR += arc
SUBDIR += arj
+ SUBDIR += ark
SUBDIR += ark-kde4
SUBDIR += atool
SUBDIR += bicom
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
new file mode 100644
index 000000000000..ce6264361da3
--- /dev/null
+++ b/archivers/ark/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= ark
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= archivers kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Archiving tool for KDE
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake:outsource gettext libarchive kde:5 tar:xz
+USE_KDE= archive auth bookmarks codecs completion config configwidgets \
+ coreaddons crash dbusaddons doctools ecm i18n iconthemes \
+ itemmodels itemviews jobwidgets khtml kio parts pty service \
+ solid sonnet textwidgets widgetsaddons xmlgui
+USE_QT5= concurrent core dbus gui network widgets xml \
+ buildtools_build qmake_build
+
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= 7ZIP RAR ZIP
+OPTIONS_SUB= YES
+
+7ZIP_DESC= Support for 7-Zip archives
+7ZIP_RUN_DEPENDS= 7z:archivers/p7zip
+
+RAR_DESC= Support for RAR archives
+RAR_RUN_DEPENDS= unrar:archivers/unrar \
+ rar:archivers/rar
+
+ZIP_DESC= Support for ZIP archives
+ZIP_LIB_DEPENDS= libzip.so:archivers/libzip
+ZIP_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_LibZip
+
+.include <bsd.port.mk>
diff --git a/archivers/ark/distinfo b/archivers/ark/distinfo
new file mode 100644
index 000000000000..df645476cdcf
--- /dev/null
+++ b/archivers/ark/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519237
+SHA256 (KDE/applications/17.12.3/ark-17.12.3.tar.xz) = b13d102e06eeaf080270a710a6b82d11d444fde78f0c701ac5efca682cfb5642
+SIZE (KDE/applications/17.12.3/ark-17.12.3.tar.xz) = 1970120
diff --git a/archivers/ark/pkg-descr b/archivers/ark/pkg-descr
new file mode 100644
index 000000000000..dfdfed20b0d5
--- /dev/null
+++ b/archivers/ark/pkg-descr
@@ -0,0 +1,11 @@
+Ark is a program for managing various archive formats within the KDE
+environment.
+
+Archives can be viewed, extracted, created and modified from within
+Ark. The program can handle various formats such as tar, gzip, bzip2,
+zip, rar and lha (if appropriate command-line programs are
+installed). Ark can work closely with Konqueror in the KDE
+environment to handle archives, if you install the Konqueror
+Integration plugin available in the kdeaddons package.
+
+WWW: https://utils.kde.org/
diff --git a/archivers/ark/pkg-plist b/archivers/ark/pkg-plist
new file mode 100644
index 000000000000..57bca45a0d25
--- /dev/null
+++ b/archivers/ark/pkg-plist
@@ -0,0 +1,96 @@
+bin/ark
+etc/xdg/ark.categories
+lib/libkerfuffle.so.17
+lib/libkerfuffle.so.%%KDE_APPLICATIONS_VERSION%%
+%%QT_PLUGINDIR%%/arkpart.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_cli7z.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_clirar.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_cliunarchiver.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_clizip.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libarchive.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libarchive_readonly.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libbz2.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libgz.so
+%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libxz.so
+%%ZIP%%%%QT_PLUGINDIR%%/kerfuffle/kerfuffle_libzip.so
+%%QT_PLUGINDIR%%/kf5/kfileitemaction/compressfileitemaction.so
+%%QT_PLUGINDIR%%/kf5/kfileitemaction/extractfileitemaction.so
+%%QT_PLUGINDIR%%/kf5/kio_dnd/extracthere.so
+man/ca/man1/ark.1.gz
+man/de/man1/ark.1.gz
+man/es/man1/ark.1.gz
+man/fr/man1/ark.1.gz
+man/gl/man1/ark.1.gz
+man/it/man1/ark.1.gz
+man/man1/ark.1.gz
+man/nl/man1/ark.1.gz
+man/pt/man1/ark.1.gz
+man/pt_BR/man1/ark.1.gz
+man/sr/man1/ark.1.gz
+man/sv/man1/ark.1.gz
+man/uk/man1/ark.1.gz
+share/applications/org.kde.ark.desktop
+share/config.kcfg/ark.kcfg
+share/icons/hicolor/128x128/apps/ark.png
+share/icons/hicolor/48x48/apps/ark.png
+share/icons/hicolor/64x64/apps/ark.png
+share/icons/hicolor/scalable/apps/ark.svgz
+share/kservices5/ark_part.desktop
+share/kservicetypes5/kerfufflePlugin.desktop
+share/kxmlgui5/ark/ark_viewer.rc
+share/locale/ar/LC_MESSAGES/ark.mo
+share/locale/ast/LC_MESSAGES/ark.mo
+share/locale/bg/LC_MESSAGES/ark.mo
+share/locale/bs/LC_MESSAGES/ark.mo
+share/locale/ca/LC_MESSAGES/ark.mo
+share/locale/ca@valencia/LC_MESSAGES/ark.mo
+share/locale/cs/LC_MESSAGES/ark.mo
+share/locale/da/LC_MESSAGES/ark.mo
+share/locale/de/LC_MESSAGES/ark.mo
+share/locale/el/LC_MESSAGES/ark.mo
+share/locale/en_GB/LC_MESSAGES/ark.mo
+share/locale/eo/LC_MESSAGES/ark.mo
+share/locale/es/LC_MESSAGES/ark.mo
+share/locale/et/LC_MESSAGES/ark.mo
+share/locale/eu/LC_MESSAGES/ark.mo
+share/locale/fa/LC_MESSAGES/ark.mo
+share/locale/fi/LC_MESSAGES/ark.mo
+share/locale/fr/LC_MESSAGES/ark.mo
+share/locale/ga/LC_MESSAGES/ark.mo
+share/locale/gl/LC_MESSAGES/ark.mo
+share/locale/he/LC_MESSAGES/ark.mo
+share/locale/hi/LC_MESSAGES/ark.mo
+share/locale/hr/LC_MESSAGES/ark.mo
+share/locale/hu/LC_MESSAGES/ark.mo
+share/locale/ia/LC_MESSAGES/ark.mo
+share/locale/id/LC_MESSAGES/ark.mo
+share/locale/is/LC_MESSAGES/ark.mo
+share/locale/it/LC_MESSAGES/ark.mo
+share/locale/ja/LC_MESSAGES/ark.mo
+share/locale/kk/LC_MESSAGES/ark.mo
+share/locale/km/LC_MESSAGES/ark.mo
+share/locale/ko/LC_MESSAGES/ark.mo
+share/locale/lt/LC_MESSAGES/ark.mo
+share/locale/lv/LC_MESSAGES/ark.mo
+share/locale/mr/LC_MESSAGES/ark.mo
+share/locale/nb/LC_MESSAGES/ark.mo
+share/locale/nds/LC_MESSAGES/ark.mo
+share/locale/nl/LC_MESSAGES/ark.mo
+share/locale/nn/LC_MESSAGES/ark.mo
+share/locale/pa/LC_MESSAGES/ark.mo
+share/locale/pl/LC_MESSAGES/ark.mo
+share/locale/pt/LC_MESSAGES/ark.mo
+share/locale/pt_BR/LC_MESSAGES/ark.mo
+share/locale/ro/LC_MESSAGES/ark.mo
+share/locale/ru/LC_MESSAGES/ark.mo
+share/locale/sk/LC_MESSAGES/ark.mo
+share/locale/sl/LC_MESSAGES/ark.mo
+share/locale/sr/LC_MESSAGES/ark.mo
+share/locale/sv/LC_MESSAGES/ark.mo
+share/locale/tr/LC_MESSAGES/ark.mo
+share/locale/ug/LC_MESSAGES/ark.mo
+share/locale/uk/LC_MESSAGES/ark.mo
+share/locale/zh_CN/LC_MESSAGES/ark.mo
+share/locale/zh_TW/LC_MESSAGES/ark.mo
+share/metainfo/org.kde.ark.appdata.xml
+share/mime/packages/kerfuffle.xml