aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-05-07 02:39:43 +0800
committerzi <zi@FreeBSD.org>2013-05-07 02:39:43 +0800
commit7834cd6c924708952cebeeaf683e6f7557141040 (patch)
tree5c438875df6f933e6d24d0426c28911146f54bee
parent44bd359347b18b6475617ef5b17efab1aa7050ec (diff)
downloadfreebsd-ports-gnome-7834cd6c924708952cebeeaf683e6f7557141040.tar.gz
freebsd-ports-gnome-7834cd6c924708952cebeeaf683e6f7557141040.tar.zst
freebsd-ports-gnome-7834cd6c924708952cebeeaf683e6f7557141040.zip
New port: www/p5-Text-MultiMarkdown-ApacheHandler:
Processes files containing MultiMarkdown syntax into HTML files and serves them, optionally applying CSS styles according to rules in your httpd.conf or (more likely) .htaccess files. Optionally applies SmartyPants post-processing using Text::Typography. WWW: http://search.cpan.org/dist/Text-MultiMarkdown-ApacheHandler/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/Makefile30
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/distinfo2
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/files/patch-lib__Text__MultiMarkdown__ApacheHandler.pm19
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/files/pkg-message.in9
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/pkg-descr6
-rw-r--r--www/p5-Text-MultiMarkdown-ApacheHandler/pkg-plist8
7 files changed, 75 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f59f12a4e459..7e15abcd34e2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1205,6 +1205,7 @@
SUBDIR += p5-Test-HTTP
SUBDIR += p5-Test-HTTP-Server-Simple
SUBDIR += p5-TestGen4Web-Runner
+ SUBDIR += p5-Text-MultiMarkdown-ApacheHandler
SUBDIR += p5-Tie-TinyURL
SUBDIR += p5-Twiggy
SUBDIR += p5-Twiggy-TLS
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/Makefile b/www/p5-Text-MultiMarkdown-ApacheHandler/Makefile
new file mode 100644
index 000000000000..16dae940a7d8
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/Makefile
@@ -0,0 +1,30 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Text-MultiMarkdown-ApacheHandler
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Module for processing files with MultiMarkdown syntax for Apache
+
+BUILD_DEPENDS= p5-Text-MultiMarkdown>=0:${PORTSDIR}/textproc/p5-Text-MultiMarkdown \
+ p5-Text-Typography>=0:${PORTSDIR}/textproc/p5-Text-Typography \
+ ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.5:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_APACHE_RUN= 22+
+PERL_CONFIGURE= yes
+SUB_FILES= pkg-message
+
+MAN3= Text::MultiMarkdown::ApacheHandler.3
+
+post-patch:
+ @${RM} ${WRKSRC}/lib/Text/MultiMarkdown/ApacheHandler.pm.orig
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/distinfo b/www/p5-Text-MultiMarkdown-ApacheHandler/distinfo
new file mode 100644
index 000000000000..a0fdd27bfe72
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-MultiMarkdown-ApacheHandler-0.01.tar.gz) = 45552f726d878738c1ca8ce187978c2bae463292089c78cbaf0b070ab721598f
+SIZE (Text-MultiMarkdown-ApacheHandler-0.01.tar.gz) = 3676
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/files/patch-lib__Text__MultiMarkdown__ApacheHandler.pm b/www/p5-Text-MultiMarkdown-ApacheHandler/files/patch-lib__Text__MultiMarkdown__ApacheHandler.pm
new file mode 100644
index 000000000000..51686151b93d
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/files/patch-lib__Text__MultiMarkdown__ApacheHandler.pm
@@ -0,0 +1,19 @@
+--- ./lib/Text/MultiMarkdown/ApacheHandler.pm.orig 2013-05-06 13:22:18.000000000 -0400
++++ ./lib/Text/MultiMarkdown/ApacheHandler.pm 2013-05-06 13:25:56.000000000 -0400
+@@ -16,6 +16,7 @@
+
+ our $VERSION = '0.01';
+
++use Apache2::compat;
+ use Apache::Constants qw(:common);
+ use Apache::File ();
+ use Text::MultiMarkdown 'markdown';
+@@ -52,7 +53,7 @@
+ return DECLINED unless $r->content_type() eq 'text/multimarkdown';
+ my $file = $r->filename;
+
+- unless (-e $r->finfo) {
++ unless (-e $file) {
+ $r->log_error("File does not exist: $file");
+ return NOT_FOUND;
+ }
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/files/pkg-message.in b/www/p5-Text-MultiMarkdown-ApacheHandler/files/pkg-message.in
new file mode 100644
index 000000000000..6ec81263ec25
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/files/pkg-message.in
@@ -0,0 +1,9 @@
+Please create %%PREFIX%%/etc/apache22/Includes/mmd.conf
+with the following contents:
+
+AddType text/multimarkdown .markdown .mmd
+<Files ~ "\.(mmd|markdown)$">
+ SetHandler perl-script
+ PerlHandler Text::MultiMarkdown::ApacheHandler
+ PerlSetVar mm_useSmartyPants 1
+</Files>
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-descr b/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-descr
new file mode 100644
index 000000000000..e980b8597a5b
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-descr
@@ -0,0 +1,6 @@
+Processes files containing MultiMarkdown syntax into HTML files and serves
+them, optionally applying CSS styles according to rules in your httpd.conf
+or (more likely) .htaccess files. Optionally applies SmartyPants
+post-processing using Text::Typography.
+
+WWW: http://search.cpan.org/dist/Text-MultiMarkdown-ApacheHandler/
diff --git a/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-plist b/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-plist
new file mode 100644
index 000000000000..22ed20c2262a
--- /dev/null
+++ b/www/p5-Text-MultiMarkdown-ApacheHandler/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Text/MultiMarkdown/ApacheHandler.pm
+@dirrmtry %%SITE_PERL%%/Text/MultiMarkdown
+@dirrmtry %%SITE_PERL%%/Text
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/MultiMarkdown/ApacheHandler/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/MultiMarkdown/ApacheHandler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/MultiMarkdown
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text