aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-09-11 17:36:48 +0800
committermarino <marino@FreeBSD.org>2013-09-11 17:36:48 +0800
commit78b2550538ae685378dfcecb9be7ffc4107dd492 (patch)
treeaa8adbb0d08839fd3f770129dc3959a9217f13df
parent1407e95251635a835c8e1f4eb2e42b931c95f6bc (diff)
downloadfreebsd-ports-gnome-78b2550538ae685378dfcecb9be7ffc4107dd492.tar.gz
freebsd-ports-gnome-78b2550538ae685378dfcecb9be7ffc4107dd492.tar.zst
freebsd-ports-gnome-78b2550538ae685378dfcecb9be7ffc4107dd492.zip
Add explicit dependency on pkgconf (6 ports)
-rw-r--r--audio/zynaddsubfx/Makefile2
-rw-r--r--comms/gammu-devel/Makefile8
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--textproc/wv2/Makefile2
-rw-r--r--x11-toolkits/mygui/Makefile2
-rw-r--r--x11-wm/pawm/Makefile2
6 files changed, 7 insertions, 11 deletions
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index ebaba85b574f..96c3bcfd36fa 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -22,7 +22,7 @@ DSSI_DESC= DSSI Plugin
LO_DESC= Open Sound Control support via LibLO
USE_BZIP2= yes
-USES= cmake
+USES= cmake pkgconfig
PORTDOCS= *
PORTEXAMPLES= *
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 7e3c786173f1..1e5279790c19 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gammu-devel
-# Date created: 2009-10-15
-# Whom: Sylvio Cesar Teixeira <sylvio@FreeBSD.org>
-#
+# Created by: Sylvio Cesar Teixeira <sylvio@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gammu
PORTVERSION= 1.31.90
@@ -23,7 +19,7 @@ CONFLICTS= gammu-[1-9]* gammu-python-[1-9]*
CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
-USES= cmake gettext
+USES= cmake gettext pkgconfig
USE_PYTHON= yes
USE_GNOME= glib20
USE_BZIP2= yes
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 5b680405e13f..388889eebf53 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
USE_SDL= image mixer net ttf
USE_GNOME= pango desktopfileutils
USE_BZIP2= yes
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DMANDIR="man"
MAN6= wesnoth.6
diff --git a/textproc/wv2/Makefile b/textproc/wv2/Makefile
index 016b051cab3c..bb4b81e4fdfb 100644
--- a/textproc/wv2/Makefile
+++ b/textproc/wv2/Makefile
@@ -12,7 +12,7 @@ COMMENT= A library providing routines to access Microsoft Word files
USE_GNOME= libgsf
USE_BZIP2= yes
-USES= cmake iconv
+USES= cmake iconv pkgconfig
USE_LDCONFIG= yes
post-patch:
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
index d2a0fba5f271..57250fe29a12 100644
--- a/x11-toolkits/mygui/Makefile
+++ b/x11-toolkits/mygui/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
USE_ZIP= yes
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DMYGUI_BUILD_DEMOS=OFF -DMYGUI_BUILD_DOCS=OFF
USE_LDCONFIG= yes
USE_GCC= yes
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index 3dbb11e6d623..5b95f7c500a6 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -11,7 +11,7 @@ COMMENT= The Puto Amo Window Manager
USE_BZIP2= yes
USE_XORG= x11 xft xrandr xrender xpm
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DCMAKE_CONFIG_PREFIX:STRING="${PREFIX}/etc" \
-DX11_LIBRARY_DIRS:STRING="${LOCALBASE}/lib"