aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2006-09-15 01:37:05 +0800
committerbrooks <brooks@FreeBSD.org>2006-09-15 01:37:05 +0800
commit78fb7e397e468fd001d201ff511a4bf490b5d38c (patch)
treec9e425505c74a3b18526f3a6040bbd1793db2df0
parent040a6c592d8b917e63f79905b105f35eb18b062e (diff)
downloadfreebsd-ports-gnome-78fb7e397e468fd001d201ff511a4bf490b5d38c.tar.gz
freebsd-ports-gnome-78fb7e397e468fd001d201ff511a4bf490b5d38c.tar.zst
freebsd-ports-gnome-78fb7e397e468fd001d201ff511a4bf490b5d38c.zip
Fix build with openssl 0.9.8b.
PR: ports/102822 Submitted by: simon
-rw-r--r--security/wpa_supplicant/Makefile4
-rw-r--r--security/wpa_supplicant/files/patch-crypto.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 2bb1217a4032..82f35955cb9a 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -65,8 +65,4 @@ post-install:
IGNORE=is not supported on FreeBSD < 6.0
.endif
-.if ${OSVERSION} >= 700019
-BROKEN= does not compile on FreeBSD >= 7.0
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/wpa_supplicant/files/patch-crypto.c b/security/wpa_supplicant/files/patch-crypto.c
new file mode 100644
index 000000000000..c27bc4c09f64
--- /dev/null
+++ b/security/wpa_supplicant/files/patch-crypto.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- crypto.c.orig
++++ crypto.c
+@@ -12,6 +12,7 @@
+ * See README and COPYING for more details.
+ */
+
++#include <sys/types.h>
+ #include <openssl/md4.h>
+ #include <openssl/des.h>
+