aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-01-27 02:11:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-01-27 02:11:55 +0800
commit794046a77602fb4803b1aebedaef398bdd937ccb (patch)
tree1a9184c726ea080782cc06e506bc2958d2f67c17
parentc30413c2cbb01dccd16d896f720a966627b0e4c0 (diff)
downloadfreebsd-ports-gnome-794046a77602fb4803b1aebedaef398bdd937ccb.tar.gz
freebsd-ports-gnome-794046a77602fb4803b1aebedaef398bdd937ccb.tar.zst
freebsd-ports-gnome-794046a77602fb4803b1aebedaef398bdd937ccb.zip
Add LICENSE
- Update COMMENT - Add NO_ARCH - Allow concurrent installation (USE_PYTHON=concurrent) - Update pkg-descr - Update WWW - Add GitHub repository to WWW - Take maintainership
-rw-r--r--devel/py-flexmock/Makefile10
-rw-r--r--devel/py-flexmock/pkg-descr32
2 files changed, 25 insertions, 17 deletions
diff --git a/devel/py-flexmock/Makefile b/devel/py-flexmock/Makefile
index 28624eb75c76..a34d2b9094cc 100644
--- a/devel/py-flexmock/Makefile
+++ b/devel/py-flexmock/Makefile
@@ -7,10 +7,14 @@ CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Flexmock is a mock/stub/spy library for Python
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Testing library to create mocks, stubs and fakes
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/devel/py-flexmock/pkg-descr b/devel/py-flexmock/pkg-descr
index 11caa99aaf0b..825d46497ee6 100644
--- a/devel/py-flexmock/pkg-descr
+++ b/devel/py-flexmock/pkg-descr
@@ -1,18 +1,22 @@
-Flexmock is a mock/stub/spy library for Python.
+flexmock is a testing library for Python that makes it easy to create mocks,
+stubs and fakes.
-Its API is inspired by a Ruby library of the same name.
-However, it is not a goal of Python Flexmock to be a clone of
-the Ruby version. Instead, the focus is on providing full support
-for testing Python programs and making the creation of fake
-objects as unobtrusive as possible.
+Its API is inspired by a Ruby library of the same name. However, it is not a
+goal of Python flexmock to be a clone of the Ruby version. Instead, the focus is
+on providing full support for testing Python programs and making the creation of
+fake objects as unobtrusive as possible.
-As a result, Python Flexmock removes a number of redandancies in
-the Ruby Flexmock API, alters some defaults, and introduces a
-number of Python-only features.
+As a result, Python flexmock removes a number of redundancies in the Ruby
+flexmock API, alters some defaults, and introduces a number of Python-only
+features.
-Flexmock declarations are structured to read more like English
-sentences than API calls, and it is possible to chain them
-together in any order to achieve high degree of expressiveness
-in a single line of code.
+flexmock's design focuses on simplicity and intuitivenes. This means that the
+API is as lean as possible, though a few convenient short-hand methods are
+provided to aid brevity and readability.
-WWW: http://has207.github.com/flexmock/
+flexmock declarations are structured to read more like English sentences than
+API calls, and it is possible to chain them together in any order to achieve
+high degree of expressiveness in a single line of code.
+
+WWW: https://pypi.python.org/pypi/flexmock
+WWW: https://github.com/bkabrda/flexmock