aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleres <leres@FreeBSD.org>2017-12-02 05:38:03 +0800
committerleres <leres@FreeBSD.org>2017-12-02 05:38:03 +0800
commit79a9bbeee7599724b58bf4254bdfb4c69875e5dd (patch)
tree131f87fdbf0ca4613b93da157c294b9c3481c137
parent986c2efc8dc353221f0561a835790fe04a8e2a8b (diff)
downloadfreebsd-ports-gnome-79a9bbeee7599724b58bf4254bdfb4c69875e5dd.tar.gz
freebsd-ports-gnome-79a9bbeee7599724b58bf4254bdfb4c69875e5dd.tar.zst
freebsd-ports-gnome-79a9bbeee7599724b58bf4254bdfb4c69875e5dd.zip
This adds devel/arduino-bsd-mk which installs a make(1) makefile
(bsd.arduino.mk) that is used to build Arduino sketches from the command line. It is designed to be a FreeBSD-friendly alternative to the existing gmake based devel/arduino-mk port. It includes a man page and optionally installs an example sketch with an exmaple Makefile. Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D13262
-rw-r--r--devel/Makefile1
-rw-r--r--devel/arduino-bsd-mk/Makefile44
-rw-r--r--devel/arduino-bsd-mk/distinfo3
-rw-r--r--devel/arduino-bsd-mk/pkg-descr8
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5c53ce764ec6..7968f44083b5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -116,6 +116,7 @@
SUBDIR += arcanist
SUBDIR += arduino
SUBDIR += arduino-avrdude
+ SUBDIR += arduino-bsd-mk
SUBDIR += arduino-builder
SUBDIR += arduino-core
SUBDIR += arduino-ctags
diff --git a/devel/arduino-bsd-mk/Makefile b/devel/arduino-bsd-mk/Makefile
new file mode 100644
index 000000000000..1ea0340fa021
--- /dev/null
+++ b/devel/arduino-bsd-mk/Makefile
@@ -0,0 +1,44 @@
+# Created by: Craig Leres <leres@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= arduino-bsd-mk
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= https://xse.com/leres/arduino/arduino-bsd-mk/ \
+ LOCAL/leres/arduino-bsd-mk
+
+MAINTAINER= leres@FreeBSD.org
+COMMENT= Build Arduino sketches from the command line on FreeBSD
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= arduino:devel/arduino \
+ avr-gcc:devel/avr-gcc
+
+USES= python:2.7,run shebangfix
+
+SHEBANG_FILES= arduino-boards.py
+
+NO_BUILD= yes
+NO_MTREE= yes
+
+PORTEXAMPLES= *
+
+PLIST_FILES= ${ALL_FILES} ${ALL_SCRIPTS:R} man/man7/bsd.arduino.mk.7.gz
+
+OPTIONS_DEFINE+= EXAMPLES
+
+ALL_FILES= arduino-bsd-mk/bsd.arduino.mk
+
+ALL_SCRIPTS= arduino-bsd-mk/scripts/arduino-boards.py \
+ arduino-bsd-mk/scripts/arduino-version.sh \
+ arduino-bsd-mk/scripts/gcc-version.sh
+
+pre-patch:
+ # Honor PREFIX in the man page
+ ${REINPLACE_CMD} -e 's,/usr/local/,${PREFIX}/,' ${WRKSRC}/bsd.arduino.mk.7
+
+post-install:
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}$/${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/devel/arduino-bsd-mk/distinfo b/devel/arduino-bsd-mk/distinfo
new file mode 100644
index 000000000000..77eeb3360c18
--- /dev/null
+++ b/devel/arduino-bsd-mk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511936799
+SHA256 (arduino-bsd-mk-1.0.tar.gz) = 4c66f1e9a76760c8fb6e0f809f0f484524be05ec4e1cc30c293c0fe262e37549
+SIZE (arduino-bsd-mk-1.0.tar.gz) = 9135
diff --git a/devel/arduino-bsd-mk/pkg-descr b/devel/arduino-bsd-mk/pkg-descr
new file mode 100644
index 000000000000..b8d83fc07306
--- /dev/null
+++ b/devel/arduino-bsd-mk/pkg-descr
@@ -0,0 +1,8 @@
+Arduino from the command line on FreeBSD
+
+This is a makefile written by Craig Leres that makes it possible
+to build Arduino sketches with FreeBSD make from the command line.
+It includes an example sketch and Makefile which is optionally
+installed in share/examples/arduino-bsd-mk
+
+WWW: https://xse.com/leres/arduino/arduino-bsd-mk/