aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2009-10-21 23:46:57 +0800
committervsevolod <vsevolod@FreeBSD.org>2009-10-21 23:46:57 +0800
commit79c6e36ff8cf1adbe787f1495844f578b83eed70 (patch)
treeaee033913e3cb11f821503567649bbfbf6de1c7e
parent5937ad931f0eadb60e31e5a1f72af2e772d573b1 (diff)
downloadfreebsd-ports-gnome-79c6e36ff8cf1adbe787f1495844f578b83eed70.tar.gz
freebsd-ports-gnome-79c6e36ff8cf1adbe787f1495844f578b83eed70.tar.zst
freebsd-ports-gnome-79c6e36ff8cf1adbe787f1495844f578b83eed70.zip
Fix dependency issues when installing with different PREFIX and LOCALBASE.
PR: 139555 Submitted by: Sahil Tandon <sahil at tandon.net>
-rw-r--r--mail/rmilter/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/mail/rmilter/Makefile b/mail/rmilter/Makefile
index fde27914cf26..4bd08da54ff7 100644
--- a/mail/rmilter/Makefile
+++ b/mail/rmilter/Makefile
@@ -16,6 +16,10 @@ COMMENT= Milter plugin for rambler mail
PLIST_FILES= sbin/rmilter etc/rc.d/rmilter.sh etc/rmilter.conf.sample
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
.ifdef WITH_DEBUG
CONFIGURE_ARGS+= --enable-debug