aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-03-04 07:12:06 +0800
committerjbeich <jbeich@FreeBSD.org>2018-03-04 07:12:06 +0800
commit7aab2c73db40f194a33979bace9f8e8932765b70 (patch)
tree5f949df97bdbacf4136e6cdb1d33aef7c72749c8
parent9e79efd66a82ea3817cf0be3542b6d3321ed10fb (diff)
downloadfreebsd-ports-gnome-7aab2c73db40f194a33979bace9f8e8932765b70.tar.gz
freebsd-ports-gnome-7aab2c73db40f194a33979bace9f8e8932765b70.tar.zst
freebsd-ports-gnome-7aab2c73db40f194a33979bace9f8e8932765b70.zip
security/clamfs: unbreak with boost 1.65
PR: 220725 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Approved by: maintainer timeout (7 months)
-rw-r--r--security/clamfs/Makefile8
-rw-r--r--security/clamfs/files/patch-src_config.hxx23
2 files changed, 24 insertions, 7 deletions
diff --git a/security/clamfs/Makefile b/security/clamfs/Makefile
index a56a77e4e77b..578011ee64e0 100644
--- a/security/clamfs/Makefile
+++ b/security/clamfs/Makefile
@@ -12,10 +12,6 @@ COMMENT= User-space fs with on-access antivirus scanning
LICENSE= GPLv2
-BROKEN= fails to build with boost 1.65, see bug 220725
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2018-03-19
-
LIB_DEPENDS= libccgnu2.so:devel/commoncpp \
libPocoNet.so:devel/poco-ssl \
librlog.so:devel/rlog
@@ -24,9 +20,7 @@ RUN_DEPENDS= clamd:security/clamav
GNU_CONFIGURE= yes
-USES= fuse
-
-CPPFLAGS+= -I${LOCALBASE}/include/boost/tr1
+USES= compiler:c++11-lib fuse
PLIST_FILES= bin/clamfs \
man/man1/clamfs.1.gz
diff --git a/security/clamfs/files/patch-src_config.hxx b/security/clamfs/files/patch-src_config.hxx
new file mode 100644
index 000000000000..194abd1022f5
--- /dev/null
+++ b/security/clamfs/files/patch-src_config.hxx
@@ -0,0 +1,23 @@
+--- src/config.hxx.orig 2009-11-29 19:19:33 UTC
++++ src/config.hxx
+@@ -30,7 +30,7 @@
+ #include "config.h"
+
+ #include <map>
+-#include <tr1/unordered_map>
++#include <unordered_map>
+ #include <cc++/xml.h>
+
+ #ifdef DMALLOC
+@@ -45,11 +45,6 @@ namespace clamfs {
+ \brief STanDard namespace
+ */
+ using namespace std;
+-
+-/*!\namespace tr1
+- \brief ISO/IEC TR 19768 namespace
+-*/
+-using namespace tr1;
+
+ /*!\namespace ost
+ \brief GNU CommonC++ namespace