aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2010-02-06 15:49:05 +0800
committeredwin <edwin@FreeBSD.org>2010-02-06 15:49:05 +0800
commit7add3c638c692ccedf60bec884fa23d7bda81722 (patch)
tree3b1a0f551953a1bc02d775f36495b581a3c9a29e
parent9ff9cfa470c68cea5b942b71ed41df22f2c7c931 (diff)
downloadfreebsd-ports-gnome-7add3c638c692ccedf60bec884fa23d7bda81722.tar.gz
freebsd-ports-gnome-7add3c638c692ccedf60bec884fa23d7bda81722.tar.zst
freebsd-ports-gnome-7add3c638c692ccedf60bec884fa23d7bda81722.zip
Update to verison 1.1.b1
Submitted by: netherby on #bugs
-rw-r--r--mail/archivesmtp/Makefile13
-rw-r--r--mail/archivesmtp/distinfo6
-rw-r--r--mail/archivesmtp/files/archivesmtp.in4
-rw-r--r--mail/archivesmtp/files/pkg-message.in2
-rw-r--r--mail/archivesmtp/files/src-Makefile6
-rw-r--r--mail/archivesmtp/pkg-descr5
6 files changed, 22 insertions, 14 deletions
diff --git a/mail/archivesmtp/Makefile b/mail/archivesmtp/Makefile
index 876550b821ec..a0afda16bc3f 100644
--- a/mail/archivesmtp/Makefile
+++ b/mail/archivesmtp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= archivesmtp
-PORTVERSION= 1.0.b1
+PORTVERSION= 1.1.b1
CATEGORIES= mail
MASTER_SITES= http://www.dancingfortune.com/projects/archivesmtp/files/
@@ -14,15 +14,16 @@ MAINTAINER= contact@dancingfortune.com
COMMENT= SMTP mail archiver
CFLAGS+= ${PTHREAD_CFLAGS}
-LIBS+= ${PTHREAD_LIBS} -lmilter
-MAKE_ENV+= LDADD="${LIBS}" \
- BINDIR="${PREFIX}/sbin" \
- MANDIR="${MANPREFIX}/man/man" \
+LIBS+= ${PTHREAD_LIBS}\
+ -lmilter
+MAKE_ENV+= LDADD="${LIBS}"\
+ BINDIR="${PREFIX}/sbin"\
+ MANDIR="${MANPREFIX}/man/man"\
NO_MANCOMPRESS="yes"
USE_RC_SUBR= archivesmtp
SUB_FILES= pkg-message
-SUB_LIST= SOCKETBASE=${SOCKETBASE} \
+SUB_LIST+= SOCKETBASE=${SOCKETBASE}\
SOCKETDIR=${SOCKETDIR}
PLIST_SUB+= ${SUB_LIST}
diff --git a/mail/archivesmtp/distinfo b/mail/archivesmtp/distinfo
index 2dd6c6e68aee..86b033cbf988 100644
--- a/mail/archivesmtp/distinfo
+++ b/mail/archivesmtp/distinfo
@@ -1,3 +1,3 @@
-MD5 (archivesmtp-1.0.b1.tar.gz) = f5efe43c68afddead393dc8de39a0f5a
-SHA256 (archivesmtp-1.0.b1.tar.gz) = 32c85cc4aa741a50fd837c89ad28eea44f0d4ba58500c034868e090a7f4602b8
-SIZE (archivesmtp-1.0.b1.tar.gz) = 95646
+MD5 (archivesmtp-1.1.b1.tar.gz) = bc77cb8cbfeada6b5e0bc507c5b18e07
+SHA256 (archivesmtp-1.1.b1.tar.gz) = 0b4c8ddb15262721801c929fd104549c63d569af82ba9aaa5d26294ad88f72d8
+SIZE (archivesmtp-1.1.b1.tar.gz) = 101835
diff --git a/mail/archivesmtp/files/archivesmtp.in b/mail/archivesmtp/files/archivesmtp.in
index 3653b330931e..37bee1625c6e 100644
--- a/mail/archivesmtp/files/archivesmtp.in
+++ b/mail/archivesmtp/files/archivesmtp.in
@@ -6,12 +6,12 @@
. %%RC_SUBR%%
name="archivesmtp"
-rcvar="${name}_enable"
+rcvar=`set_rcvar`
command="%%PREFIX%%/sbin/${name}"
# Read settings and set defaults
-load_rc_config $name
+load_rc_config "$name"
: ${archivesmtp_enable="NO"}
: ${archivesmtp_chuser="nobody"}
diff --git a/mail/archivesmtp/files/pkg-message.in b/mail/archivesmtp/files/pkg-message.in
index 8d7940e5912d..916e7f8d4e5b 100644
--- a/mail/archivesmtp/files/pkg-message.in
+++ b/mail/archivesmtp/files/pkg-message.in
@@ -11,7 +11,7 @@
Filter socket -> archivesmtp_socket="unix:%%SOCKETBASE%%/%%SOCKETDIR%%/mta.sock"
Pid file -> archivesmtp_pidfile="%%SOCKETBASE%%/%%SOCKETDIR%%/run.pid"
Configuration -> archivesmtp_config="%%PREFIX%%/etc/archivesmtp.conf"
- Other Flags -> archuvesmtp_flags=""
+ Other Flags -> archivesmtp_flags=""
Please note: Only the owner my have write permissions on the socket directory.
diff --git a/mail/archivesmtp/files/src-Makefile b/mail/archivesmtp/files/src-Makefile
index 2294c4c1fb3c..7b23199cc9b1 100644
--- a/mail/archivesmtp/files/src-Makefile
+++ b/mail/archivesmtp/files/src-Makefile
@@ -1,5 +1,9 @@
PROG= archivesmtp
-SRCS= ArchiveSMTP.c
+SRCS= ArchiveSMTP.c\
+ Rule.c\
+ Condition.c\
+ Test.c\
+ Action.c
MAN= archivesmtp.8
.include <bsd.prog.mk>
diff --git a/mail/archivesmtp/pkg-descr b/mail/archivesmtp/pkg-descr
index 1ab78a6ed532..4a8239158b3e 100644
--- a/mail/archivesmtp/pkg-descr
+++ b/mail/archivesmtp/pkg-descr
@@ -1,6 +1,9 @@
ArchiveSMTP is a mail archiver designed to be run on an SMTP mail server. It
uses rule-based matching to collect and store mail passing through an MTA to
-specific locations in mbox format. The libmilter interface is used and must be
+specific locations in mbox format. Adding headers and piping output to other
+programs is also supported. The libmilter interface is used and must be
supported by the MTA for ArchiveSMTP to work.
+Version: 1.1.b1
+
WWW: http://www.dancingfortune.com/projects/archivesmtp/