aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-10 23:47:22 +0800
committermarino <marino@FreeBSD.org>2016-09-10 23:47:22 +0800
commit7b35a0151813031073b1dbac840d100a0c7339c3 (patch)
tree497ec495e54ec17c34759aca630d453cc625691b
parent8ce801335a66a1a02156f390b1622c2a0857e60a (diff)
downloadfreebsd-ports-gnome-7b35a0151813031073b1dbac840d100a0c7339c3.tar.gz
freebsd-ports-gnome-7b35a0151813031073b1dbac840d100a0c7339c3.tar.zst
freebsd-ports-gnome-7b35a0151813031073b1dbac840d100a0c7339c3.zip
devel/objecthash: document SSL requirement
-rw-r--r--devel/objecthash/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/objecthash/Makefile b/devel/objecthash/Makefile
index 29238724d1eb..73321be4ffef 100644
--- a/devel/objecthash/Makefile
+++ b/devel/objecthash/Makefile
@@ -12,13 +12,12 @@ COMMENT= Cross-language way to cryptographically hash JSON objects
LICENSE= APACHE20
BROKEN_powerpc64= Does not build
+BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
LIB_DEPENDS= libicudata.so:devel/icu \
libjson-c.so:devel/json-c
-BROKEN_FreeBSD_9= does not build on FreeBSD < 10.x
-
-USES= pkgconfig
+USES= pkgconfig ssl
USE_GITHUB= yes
USE_LDCONFIG= yes
GH_ACCOUNT= benlaurie
@@ -30,7 +29,7 @@ ALL_TARGET= libobjecthash.so
PLIST_FILES= include/objecthash.h lib/libobjecthash.so
do-install:
- ${INSTALL_LIB} ${WRKSRC}/libobjecthash.so ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/objecthash.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${WRKSRC}/libobjecthash.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/objecthash.h ${STAGEDIR}${PREFIX}/include
.include <bsd.port.mk>